aboutsummaryrefslogtreecommitdiffstats
path: root/package/iptables/Makefile
diff options
context:
space:
mode:
authorTim Yardley <lst@openwrt.org>2006-11-26 23:13:49 +0000
committerTim Yardley <lst@openwrt.org>2006-11-26 23:13:49 +0000
commit9fa319b4c8a6313ea88f54ade76824be21656822 (patch)
tree8f0416774252929e033e7018878744f7923bd1f2 /package/iptables/Makefile
parent98df8ada4071d19147d6cc4dbd3eca9b693a5ab3 (diff)
downloadmaster-187ad058-9fa319b4c8a6313ea88f54ade76824be21656822.tar.gz
master-187ad058-9fa319b4c8a6313ea88f54ade76824be21656822.tar.bz2
master-187ad058-9fa319b4c8a6313ea88f54ade76824be21656822.zip
cleanup some of the custom work for devel libs
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5651 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/iptables/Makefile')
-rw-r--r--package/iptables/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/package/iptables/Makefile b/package/iptables/Makefile
index 862797e315..962ca7d0ef 100644
--- a/package/iptables/Makefile
+++ b/package/iptables/Makefile
@@ -173,7 +173,7 @@ define Build/Compile
COPT_FLAGS="$(TARGET_CFLAGS)" \
KERNEL_DIR="$(LINUX_DIR)" PREFIX=/usr \
DESTDIR="$(PKG_INSTALL_DIR)" \
- all install install-devel
+ all install
endef
define Build/InstallDev
@@ -182,13 +182,20 @@ define Build/InstallDev
COPT_FLAGS="$(TARGET_CFLAGS)" \
KERNEL_DIR="$(LINUX_DIR)" PREFIX=/usr \
DESTDIR="$(STAGING_DIR)" \
- install install-devel
+ install-devel
$(CP) $(PKG_BUILD_DIR)/include $(STAGING_DIR)/usr
+ $(CP) $(PKG_BUILD_DIR)/libiptc/libiptc.a $(STAGING_DIR)/usr/lib
endef
define Build/UninstallDev
- rm -rf $(STAGING_DIR)/usr/include/libipq.h
+ rm -rf $(STAGING_DIR)/usr/include/libipulog
+ rm -rf $(STAGING_DIR)/usr/include/libipq
+ rm -rf $(STAGING_DIR)/usr/include/libiptc
+ rm -rf $(STAGING_DIR)/usr/include/linux/netfilter*
+ rm -rf $(STAGING_DIR)/usr/include/iptables*
+ rm -rf $(STAGING_DIR)/usr/include/ip6tables*
rm -rf $(STAGING_DIR)/usr/lib/libipq.a
+ rm -rf $(STAGING_DIR)/usr/lib/libiptc.a
endef
define Package/iptables/install