aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-12-17 02:47:16 +0000
committerLuka Perkov <luka@openwrt.org>2013-12-17 02:47:16 +0000
commit08392999d954fd8a986179af55029be627bef499 (patch)
treecffd3587db06f4d5d27d141d8ce816eb03fc0602 /package/kernel/linux/modules/other.mk
parent4596b5cdc5c2530569257f3383368eaf5d921273 (diff)
downloadmaster-187ad058-08392999d954fd8a986179af55029be627bef499.tar.gz
master-187ad058-08392999d954fd8a986179af55029be627bef499.tar.bz2
master-187ad058-08392999d954fd8a986179af55029be627bef499.zip
kernel: add rtc-ds1672 module support
Signed-off-by: Tim Harvey <tharvey@gateworks.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39110 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index d8d437fa62..c1adc66c52 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -485,6 +485,23 @@ endef
$(eval $(call KernelPackage,pwm-gpio))
+define KernelPackage/rtc-ds1672
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Dallas/Maxim DS1672 RTC support
+ $(call AddDepends/rtc)
+ DEPENDS+=+kmod-i2c-core
+ KCONFIG:=CONFIG_RTC_DRV_DS1672
+ FILES:=$(LINUX_DIR)/drivers/rtc/rtc-ds1672.ko
+ AUTOLOAD:=$(call AutoProbe,rtc-ds1672)
+endef
+
+define KernelPackage/rtc-ds1672/description
+ Kernel module for Dallas/Maxim DS1672 RTC.
+endef
+
+$(eval $(call KernelPackage,rtc-ds1672))
+
+
define KernelPackage/rtc-isl1208
SUBMENU:=$(OTHER_MENU)
TITLE:=Intersil ISL1208 RTC support