aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2014-10-31 22:02:07 +0000
committerHauke Mehrtens <hauke@openwrt.org>2014-10-31 22:02:07 +0000
commit3324847acc9f5a1e4a9adc5a211584ca91e1b79d (patch)
tree487da235e397d8cc833e522e515b6b205af141ce /package/kernel/linux/modules/other.mk
parent0077b4c46af5fd3229a4b7e448bf927878be5a16 (diff)
downloadmaster-187ad058-3324847acc9f5a1e4a9adc5a211584ca91e1b79d.tar.gz
master-187ad058-3324847acc9f5a1e4a9adc5a211584ca91e1b79d.tar.bz2
master-187ad058-3324847acc9f5a1e4a9adc5a211584ca91e1b79d.zip
packages: kernel: negate kernel version checks
Only list the kernel versions that do not match so that new kernel versions will automatically match. This improves support for kernel 3.18. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43132 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index c514fd7366..2f9831b16c 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -13,7 +13,7 @@ WATCHDOG_DIR:=watchdog
define KernelPackage/6lowpan-iphc
USBMENU:=$(OTHER_MENU)
TITLE:=6lowpan shared code
- DEPENDS:=@LINUX_3_14
+ DEPENDS:=@!LINUX_3_3 @!LINUX_3_8 @!LINUX_3_10 @!LINUX_3_13
KCONFIG:=CONFIG_6LOWPAN_IPHC
HIDDEN:=1
FILES:=$(LINUX_DIR)/net/ieee802154/6lowpan_iphc.ko
@@ -29,7 +29,7 @@ $(eval $(call KernelPackage,6lowpan-iphc))
define KernelPackage/bluetooth
SUBMENU:=$(OTHER_MENU)
TITLE:=Bluetooth support
- DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +LINUX_3_14:kmod-6lowpan-iphc
+ DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +(!LINUX_3_3&&!LINUX_3_8&&!LINUX_3_10&&!LINUX_3_13):kmod-6lowpan-iphc
KCONFIG:= \
CONFIG_BLUEZ \
CONFIG_BLUEZ_L2CAP \