aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-04-16 10:44:11 +0000
committerNicolas Thill <nico@openwrt.org>2010-04-16 10:44:11 +0000
commit12c2cbceaca4fb4899683b938f0e193aabf76270 (patch)
tree5aa9cf3ccf0b720b32f77898f1293963553ee646 /package/kernel
parente5127b11a83ed3e7b3ec3c4522d8ad4464777ec9 (diff)
downloadmaster-187ad058-12c2cbceaca4fb4899683b938f0e193aabf76270.tar.gz
master-187ad058-12c2cbceaca4fb4899683b938f0e193aabf76270.tar.bz2
master-187ad058-12c2cbceaca4fb4899683b938f0e193aabf76270.zip
package/kernel: add dependencies on kmod-crc16 and kmod-rfkill to kmod-bluetooth (closes: #7063)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20913 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/other.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index cc2e10f823..97ce3d3b70 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -261,7 +261,8 @@ $(eval $(call KernelPackage,ssb))
define KernelPackage/bluetooth
SUBMENU:=$(OTHER_MENU)
TITLE:=Bluetooth support
- DEPENDS:=@USB_SUPPORT +kmod-usb-core +!TARGET_x86:kmod-hid
+ DEPENDS:=@USB_SUPPORT +kmod-crc16 +kmod-usb-core +!TARGET_x86:kmod-hid \
+ +(TARGET_x86||TARGET_s3c24xx||TARGET_brcm47xx||TARGET_ar71xx):kmod-rfkill
KCONFIG:= \
CONFIG_BLUEZ \
CONFIG_BLUEZ_L2CAP \