aboutsummaryrefslogtreecommitdiffstats
path: root/package/kexec-tools/Makefile
diff options
context:
space:
mode:
authorJeremy Kerr <jk@ozlabs.org>2008-04-12 23:20:31 +0000
committerJeremy Kerr <jk@ozlabs.org>2008-04-12 23:20:31 +0000
commit0fb0641427172f1a3926f7b1b59eff563844a1f5 (patch)
tree66f0f8bb902d096a01dd6d60b80fee64e2c03ce5 /package/kexec-tools/Makefile
parente5eb1146975a5c28309801965af3d2fb0f98141e (diff)
downloadmaster-187ad058-0fb0641427172f1a3926f7b1b59eff563844a1f5.tar.gz
master-187ad058-0fb0641427172f1a3926f7b1b59eff563844a1f5.tar.bz2
master-187ad058-0fb0641427172f1a3926f7b1b59eff563844a1f5.zip
[package/kexec] Use new kexec tools
Horms' new kexec-tools repository has a number of updates and fixes for kexec, and also supports the PS3. This change updates the kexec repo, and adds a few build-system patches to make it work with OpenWRT. Signed-off-by: Jeremy Kerr <jk@ozlabs.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10803 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kexec-tools/Makefile')
-rw-r--r--package/kexec-tools/Makefile51
1 files changed, 31 insertions, 20 deletions
diff --git a/package/kexec-tools/Makefile b/package/kexec-tools/Makefile
index 6274cb81c3..108492dbbf 100644
--- a/package/kexec-tools/Makefile
+++ b/package/kexec-tools/Makefile
@@ -9,46 +9,57 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=kexec-tools
-PKG_VERSION:=1.101
+PKG_VERSION:=testing-20080227
PKG_RELEASE:=1
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.xmission.com/~ebiederm/files/kexec/
-PKG_MD5SUM:=b4f7ffcc294d41a6a4c40d6e44b7734d
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://kernel.org/pub/linux/kernel/people/horms/kexec-tools/
+PKG_MD5SUM:=45455af789545fdfaff2401d1988996a
include $(INCLUDE_DIR)/package.mk
define Package/kexec-tools
SECTION:=utils
CATEGORY:=Utilities
- DEPENDS:=@i386 +zlib
+ DEPENDS:=@i386||@powerpc +zlib
TITLE:=Kernel boots kernel
- URL:=http://www.xmission.com/~ebiederm/files/kexec/README
+ URL:=http://kernel.org/pub/linux/kernel/people/horms/kexec-tools/
+ MENU:=1
endef
define Package/kexec-tools/description
- kexec is a set of systems call that allows you to load
+ kexec is a set of systems call that allows you to load
another kernel from the currently executing Linux kernel.
endef
-MAKE_FLAGS += \
- DESTDIR="$(PKG_INSTALL_DIR)" \
- EXTRA_CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS)" \
- BUILD_CFLAGS="-Os" \
- LIBS="$(TARGET_LDFLAGS) -lz" \
- install
+define Package/kexec-tools/config
+ source "$(SOURCE)/kexec-config.in"
+endef
+
+CONFIGURE_ARGS = \
+ --target=$(CONFIG_KEXEC_TOOLS_TARGET_NAME)-linux-uclibc \
+ --host=$(GNU_TARGET_NAME)-uclibc \
+ --build=$(GNU_HOST_NAME) \
+ --program-prefix="" \
+ --program-suffix="" \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --sbindir=/usr/sbin \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc \
+
+CONFIGURE_VARS += BUILD_CC=$(HOSTCC)
define Build/Compile
- rm -rf $(PKG_INSTALL_DIR)
- mkdir -p $(PKG_INSTALL_DIR)
- $(call Build/Compile/Default,)
+ $(MAKE) -C $(PKG_BUILD_DIR) all
endef
define Package/kexec-tools/install
- $(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/kexec $(1)/usr/bin/
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/kdump $(1)/usr/bin/
- $(INSTALL_BIN) ./files/kexec.sh $(1)/usr/bin/kexec.mtd
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ DESTDIR="$(1)" \
+ install
+ rm -rf $(1)/usr/man
endef
$(eval $(call BuildPackage,kexec-tools))