aboutsummaryrefslogtreecommitdiffstats
path: root/package/libnl-tiny/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-04-30 13:57:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-04-30 13:57:29 +0000
commit170da602da28b9401d043e068fe4192aeb064d0e (patch)
treea15d257ea63d5208cf9c790366af0d3d3eed4eec /package/libnl-tiny/Makefile
parentfdcbeac21e079561b07d9584392ca1a02bbe7307 (diff)
downloadmaster-187ad058-170da602da28b9401d043e068fe4192aeb064d0e.tar.gz
master-187ad058-170da602da28b9401d043e068fe4192aeb064d0e.tar.bz2
master-187ad058-170da602da28b9401d043e068fe4192aeb064d0e.zip
add libnl-tiny as a small replacement for libnl with only genl support included
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15507 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/libnl-tiny/Makefile')
-rw-r--r--package/libnl-tiny/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/package/libnl-tiny/Makefile b/package/libnl-tiny/Makefile
new file mode 100644
index 0000000000..46a72593d1
--- /dev/null
+++ b/package/libnl-tiny/Makefile
@@ -0,0 +1,49 @@
+#
+# Copyright (C) 2006-2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libnl-tiny
+PKG_VERSION:=0.1
+PKG_RELEASE:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libnl-tiny
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=netlink socket library
+endef
+
+define Package/libnl-tiny/description
+ This package contains a stripped down version of libnl
+endef
+
+define Build/Prepare
+ mkdir -p $(PKG_BUILD_DIR)
+ $(CP) ./src/* $(PKG_BUILD_DIR)/
+endef
+
+define Build/Compile
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ $(TARGET_CONFIGURE_OPTS) \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ all
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/lib $(1)/usr/include/libnl-tiny
+ $(CP) $(PKG_BUILD_DIR)/include/* $(1)/usr/include/libnl-tiny
+ $(CP) $(PKG_BUILD_DIR)/libnl-tiny.so $(1)/usr/lib/
+endef
+
+define Package/libnl-tiny/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_BUILD_DIR)/libnl-tiny.so $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libnl-tiny))