aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/gettext-full/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-10-10 17:58:23 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-10-10 17:58:23 +0000
commit72d516ef89b1f50a9c8bc7eada6b231ecd826dd8 (patch)
tree81bdeeace5d266416f9c3b9cefad21d6ece4cbf5 /package/libs/gettext-full/Makefile
parent1e06752a51b08dae12dfbac4e0704ff121c59928 (diff)
downloadmaster-187ad058-72d516ef89b1f50a9c8bc7eada6b231ecd826dd8.tar.gz
master-187ad058-72d516ef89b1f50a9c8bc7eada6b231ecd826dd8.tar.bz2
master-187ad058-72d516ef89b1f50a9c8bc7eada6b231ecd826dd8.zip
gettext-full: move to trunk and add myself as maintainer
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33713 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/libs/gettext-full/Makefile')
-rw-r--r--package/libs/gettext-full/Makefile69
1 files changed, 69 insertions, 0 deletions
diff --git a/package/libs/gettext-full/Makefile b/package/libs/gettext-full/Makefile
new file mode 100644
index 0000000000..2ae8cd3827
--- /dev/null
+++ b/package/libs/gettext-full/Makefile
@@ -0,0 +1,69 @@
+#
+# Copyright (C) 2006-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=gettext-full
+PKG_VERSION:=0.18.1.1
+PKG_RELEASE:=2
+
+PKG_SOURCE:=gettext-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@GNU/gettext
+PKG_MD5SUM:=3dd55b952826d2b32f51308f2f91aa89
+PKG_BUILD_DIR:=$(BUILD_DIR)/gettext-$(PKG_VERSION)
+HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/gettext-$(PKG_VERSION)
+
+PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
+
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=0
+PKG_BUILD_DEPENDS:=gettext-full/host
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
+
+define Package/libintl-full
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=GNU Internationalization library
+ URL:=http://www.gnu.org/software/gettext/
+endef
+
+TARGET_CFLAGS += $(FPIC)
+
+CONFIGURE_ARGS += \
+ --enable-shared \
+ --enable-static \
+ --disable-rpath \
+ --enable-nls \
+ --disable-java \
+ --disable-native-java \
+ --disable-openmp \
+ --with-included-gettext \
+ --without-libintl-prefix \
+ --without-libexpat-prefix \
+ --without-emacs
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/lib/libintl-full/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/libintl.h $(1)/usr/lib/libintl-full/include/
+
+ $(INSTALL_DIR) $(1)/usr/lib/libintl-full/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libintl.{a,so*} $(1)/usr/lib/libintl-full/lib/
+
+ $(INSTALL_DIR) $(1)/usr/share/aclocal
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/aclocal/* $(1)/usr/share/aclocal/
+endef
+
+define Package/libintl-full/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libintl.so* $(1)/usr/lib/
+endef
+
+$(eval $(call HostBuild))
+$(eval $(call BuildPackage,libintl-full))