aboutsummaryrefslogtreecommitdiffstats
path: root/package/mac80211/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-01-13 23:28:22 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-01-13 23:28:22 +0000
commit864cfd9cce20f90e7a95e919c960499f3c490567 (patch)
treecf2ebe7090c53df6f7d803505fe1d9df213737b5 /package/mac80211/Makefile
parent3bc028579596eadb3cee094b84d4df51fd4f71d0 (diff)
downloadmaster-187ad058-864cfd9cce20f90e7a95e919c960499f3c490567.tar.gz
master-187ad058-864cfd9cce20f90e7a95e919c960499f3c490567.tar.bz2
master-187ad058-864cfd9cce20f90e7a95e919c960499f3c490567.zip
mac80211: include the kfifo backport in compat.ko if necessary (fixes libertas, rt2x00)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24978 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/mac80211/Makefile')
-rw-r--r--package/mac80211/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/mac80211/Makefile b/package/mac80211/Makefile
index 5317a098eb..11564c5b05 100644
--- a/package/mac80211/Makefile
+++ b/package/mac80211/Makefile
@@ -994,6 +994,10 @@ MAKE_OPTS:= \
KLIB=$(TARGET_MODULES_DIR) \
KERNEL_SUBLEVEL=$(lastword $(subst ., ,$(KERNEL_PATCHVER)))
+ifeq ($(CONFIG_PACKAGE_kmod-libertas-sd)$(CONFIG_PACKAGE_kmod-libertas-usb)$(CONFIG_PACKAGE_kmod-rt2x00-lib),)
+ MAKE_OPTS += CONFIG_COMPAT_KFIFO=
+endif
+
define Build/Prepare
rm -rf $(PKG_BUILD_DIR)
mkdir -p $(PKG_BUILD_DIR)