aboutsummaryrefslogtreecommitdiffstats
path: root/package/ncurses
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-11-26 17:51:14 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-11-26 17:51:14 +0000
commit7a94d57241d46db5814a63120bd7f91a2d3a368c (patch)
tree69ef4d600efa1058a8eee8e582adb565bc92632c /package/ncurses
parentd5634c554baad8947adb53393b572859f8ccb6de (diff)
downloadmaster-187ad058-7a94d57241d46db5814a63120bd7f91a2d3a368c.tar.gz
master-187ad058-7a94d57241d46db5814a63120bd7f91a2d3a368c.tar.bz2
master-187ad058-7a94d57241d46db5814a63120bd7f91a2d3a368c.zip
package/ncurses: fix freebsd install issues
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24149 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/ncurses')
-rw-r--r--package/ncurses/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/package/ncurses/Makefile b/package/ncurses/Makefile
index 8fac06eca1..8043588508 100644
--- a/package/ncurses/Makefile
+++ b/package/ncurses/Makefile
@@ -51,11 +51,18 @@ CONFIGURE_ARGS += \
--without-debug \
--without-profile \
--without-progs \
+ --disable-big-core \
+ --disable-home-terminfo \
--with-normal \
--with-shared \
--with-terminfo-dirs=/usr/share/terminfo \
--with-default-terminfo-dir=/usr/share/terminfo
+ifeq ($(HOST_OS),FreeBSD)
+ CONFIGURE_ARGS +=
+ --with-terminfo=/usr/share/terminfo.db
+endif
+
ifeq ($(BUILD_VARIANT),libncursesw)
CONFIGURE_ARGS += \
--enable-widec \
@@ -78,6 +85,7 @@ endef
define Package/libncurses/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{curses,ncurses,panel,menu,form}.so* $(1)/usr/lib/
+ifneq ($(HOST_OS),FreeBSD)
$(INSTALL_DIR) $(1)/usr/share/terminfo
(cd $(PKG_INSTALL_DIR)/usr/share/terminfo; \
for dir in ??; do \
@@ -90,6 +98,7 @@ define Package/libncurses/install
$(CP) $(PKG_INSTALL_DIR)/usr/share/terminfo/$$$$file \
$(1)/usr/share/terminfo/$$$$file; \
done
+endif
endef
define Package/libncursesw/install