aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/ipv6/odhcp6c/Makefile
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2014-10-06 11:19:33 +0000
committerSteven Barth <steven@midlink.org>2014-10-06 11:19:33 +0000
commitbb492392747ea57deb54d4bbd52e5d5ce83a08a2 (patch)
treed3b010661d0368979d2616bbe8b98e6b3515ba89 /package/network/ipv6/odhcp6c/Makefile
parent415543620a1d6b57d9f561268ed93a12ad190b10 (diff)
downloadmaster-187ad058-bb492392747ea57deb54d4bbd52e5d5ce83a08a2.tar.gz
master-187ad058-bb492392747ea57deb54d4bbd52e5d5ce83a08a2.tar.bz2
master-187ad058-bb492392747ea57deb54d4bbd52e5d5ce83a08a2.zip
odhcp6c: add route-workaround for broken IPv6-ISPs
Some ISP seem to only do stateful DHCPv6 and not sending RAs. This is technically broken because plain DHCPv6 doesn't carry routes. We work around here by faking a default route to the DHCPv6 server if we do not receive a useful RA from the ISP. This workaround can be turned off with: option fakeroutes 0 Signed-off-by: Steven Barth <steven@midlink.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42803 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/ipv6/odhcp6c/Makefile')
-rw-r--r--package/network/ipv6/odhcp6c/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/network/ipv6/odhcp6c/Makefile b/package/network/ipv6/odhcp6c/Makefile
index be9c4df6fb..c7b16319c3 100644
--- a/package/network/ipv6/odhcp6c/Makefile
+++ b/package/network/ipv6/odhcp6c/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2012 OpenWrt.org
+# Copyright (C) 2012-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=odhcp6c
-PKG_VERSION:=2014-09-27
+PKG_VERSION:=2014-10-06
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_URL:=git://github.com/sbyx/odhcp6c.git
PKG_SOURCE_PROTO:=git
-PKG_SOURCE_VERSION:=3e52a1448eee0fbf7ff67c123265bedcbc9c26d0
+PKG_SOURCE_VERSION:=d6fe99f6d03873e7a670c9b6f26fa03b219422f5
PKG_MAINTAINER:=Steven Barth <steven@midlink.org>
include $(INCLUDE_DIR)/package.mk