aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/openvpn/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-12-23 14:44:24 +0000
committerJohn Crispin <blogic@openwrt.org>2015-12-23 14:44:24 +0000
commitf5cb31b10d81453a0ffe4b02b39a53ab144326a5 (patch)
tree3fffff54deb8d6230d627d775b860fd03cdaa6e3 /package/network/services/openvpn/Makefile
parent4199c658447483fdcac20e460f45b4b681aa5ae8 (diff)
downloadmaster-187ad058-f5cb31b10d81453a0ffe4b02b39a53ab144326a5.tar.gz
master-187ad058-f5cb31b10d81453a0ffe4b02b39a53ab144326a5.tar.bz2
master-187ad058-f5cb31b10d81453a0ffe4b02b39a53ab144326a5.zip
openvpn: fix configure options
- eurephia: commit: Remove the --disable-eurephia configure option - fix option name: http proxy option is now called http-proxy (see configure.ac) fixes: configure: WARNING: unrecognized options: --disable-nls, --disable-eurephia, --enable-http Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47979 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/services/openvpn/Makefile')
-rw-r--r--package/network/services/openvpn/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/package/network/services/openvpn/Makefile b/package/network/services/openvpn/Makefile
index a1784f4c85..5290b0f03b 100644
--- a/package/network/services/openvpn/Makefile
+++ b/package/network/services/openvpn/Makefile
@@ -72,7 +72,6 @@ define Build/Configure
--disable-systemd \
--disable-plugins \
--disable-debug \
- --disable-eurephia \
--disable-pkcs11 \
--enable-password-save \
$(if $(CONFIG_OPENVPN_$(BUILD_VARIANT)_ENABLE_LZO),--enable,--disable)-lzo \
@@ -80,7 +79,7 @@ define Build/Configure
$(if $(CONFIG_OPENVPN_$(BUILD_VARIANT)_ENABLE_SERVER),--enable,--disable)-server \
$(if $(CONFIG_OPENVPN_$(BUILD_VARIANT)_ENABLE_MANAGEMENT),--enable,--disable)-management \
$(if $(CONFIG_OPENVPN_$(BUILD_VARIANT)_ENABLE_SOCKS),--enable,--disable)-socks \
- $(if $(CONFIG_OPENVPN_$(BUILD_VARIANT)_ENABLE_HTTP),--enable,--disable)-http \
+ $(if $(CONFIG_OPENVPN_$(BUILD_VARIANT)_ENABLE_HTTP),--enable,--disable)-http-proxy \
$(if $(CONFIG_OPENVPN_$(BUILD_VARIANT)_ENABLE_FRAGMENT),--enable,--disable)-fragment \
$(if $(CONFIG_OPENVPN_$(BUILD_VARIANT)_ENABLE_MULTIHOME),--enable,--disable)-multihome \
$(if $(CONFIG_OPENVPN_$(BUILD_VARIANT)_ENABLE_IPROUTE2),--enable,--disable)-iproute2 \