aboutsummaryrefslogtreecommitdiffstats
path: root/package/system/opkg/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-04-14 19:00:14 +0000
committerJohn Crispin <blogic@openwrt.org>2015-04-14 19:00:14 +0000
commitdcc0f0aacdfbf90c510041063419997ae9ea3d5d (patch)
tree9c36d296610c06bf995ed22267b4a8677a06ded9 /package/system/opkg/Makefile
parente470997e7c8a346db30b85491b64a697537d7e73 (diff)
downloadmaster-187ad058-dcc0f0aacdfbf90c510041063419997ae9ea3d5d.tar.gz
master-187ad058-dcc0f0aacdfbf90c510041063419997ae9ea3d5d.tar.bz2
master-187ad058-dcc0f0aacdfbf90c510041063419997ae9ea3d5d.zip
opkg: drop md5 in favour of sha256
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45437 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/system/opkg/Makefile')
-rw-r--r--package/system/opkg/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/system/opkg/Makefile b/package/system/opkg/Makefile
index 4f30ec2114..1b1f3f19e4 100644
--- a/package/system/opkg/Makefile
+++ b/package/system/opkg/Makefile
@@ -89,11 +89,12 @@ EXTRA_CFLAGS += $(TARGET_CPPFLAGS)
CONFIGURE_ARGS += \
--disable-curl \
--disable-gpg \
+ --enable-sha256 \
--with-opkgetcdir=/etc \
--with-opkglockfile=/var/lock/opkg.lock
ifeq ($(BUILD_VARIANT),smime)
- CONFIGURE_ARGS += --enable-openssl --enable-sha256 --disable-usign
+ CONFIGURE_ARGS += --enable-openssl --disable-usign
else
ifndef CONFIG_SIGNED_PACKAGES
CONFIGURE_ARGS += --disable-usign
@@ -151,6 +152,7 @@ endef
HOST_CONFIGURE_ARGS+= \
--disable-curl \
--disable-gpg \
+ --enable-sha256 \
--with-opkgetcdir=/etc \
--with-opkglockfile=/tmp/opkg.lock