aboutsummaryrefslogtreecommitdiffstats
path: root/package/uclibc++/patches
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-10-08 11:24:12 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-10-08 11:24:12 +0000
commita17a510a62530af270844247c985073688d4d7cb (patch)
tree5155ea7bc428f0af268c4c63435d0696d18b124d /package/uclibc++/patches
parent350022b54ac1dee0e1a99ef8d6391ed60ded584d (diff)
downloadmaster-187ad058-a17a510a62530af270844247c985073688d4d7cb.tar.gz
master-187ad058-a17a510a62530af270844247c985073688d4d7cb.tar.bz2
master-187ad058-a17a510a62530af270844247c985073688d4d7cb.zip
move library packages to package/libs/
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33657 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/uclibc++/patches')
-rw-r--r--package/uclibc++/patches/002-path_to_bash.patch11
-rw-r--r--package/uclibc++/patches/006-eabi_fix.patch38
2 files changed, 0 insertions, 49 deletions
diff --git a/package/uclibc++/patches/002-path_to_bash.patch b/package/uclibc++/patches/002-path_to_bash.patch
deleted file mode 100644
index 26d88ee4dd..0000000000
--- a/package/uclibc++/patches/002-path_to_bash.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/bin/Makefile
-+++ b/bin/Makefile
-@@ -13,7 +13,7 @@ install:
- $(INSTALL) -m 755 $(WRAPPER) $(PREFIX)$(UCLIBCXX_RUNTIME_BINDIR)
-
- $(WRAPPER): Makefile
-- echo '#!/bin/sh' > $@
-+ echo '#!/usr/bin/env bash' > $@
- echo '' >> $@
- echo 'WRAPPER_INCLUDEDIR="$${WRAPPER_INCLUDEDIR:=-I$(UCLIBCXX_RUNTIME_INCLUDEDIR)}"' >> $@
- echo 'WRAPPER_LIBDIR="$${WRAPPER_LIBDIR:=-L$(UCLIBCXX_RUNTIME_LIBDIR)}"' >> $@
diff --git a/package/uclibc++/patches/006-eabi_fix.patch b/package/uclibc++/patches/006-eabi_fix.patch
deleted file mode 100644
index 65b436cde1..0000000000
--- a/package/uclibc++/patches/006-eabi_fix.patch
+++ /dev/null
@@ -1,38 +0,0 @@
---- a/include/typeinfo
-+++ b/include/typeinfo
-@@ -44,6 +44,7 @@ namespace __cxxabiv1
- class __class_type_info;
- } // namespace __cxxabiv1
-
-+#ifndef __GXX_MERGED_TYPEINFO_NAMES
- #if !__GXX_WEAK__
- // If weak symbols are not supported, typeinfo names are not merged.
- #define __GXX_MERGED_TYPEINFO_NAMES 0
-@@ -51,6 +52,7 @@ namespace __cxxabiv1
- // On platforms that support weak symbols, typeinfo names are merged.
- #define __GXX_MERGED_TYPEINFO_NAMES 1
- #endif
-+#endif
-
- namespace std
- {
---- a/include/unwind-cxx.h
-+++ b/include/unwind-cxx.h
-@@ -173,6 +173,7 @@ extern std::unexpected_handler __unexpec
-
- // This is the exception class we report -- "GNUCC++\0".
- const _Unwind_Exception_Class __gxx_exception_class
-+#ifndef __ARM_EABI_UNWINDER__
- = ((((((((_Unwind_Exception_Class) 'G'
- << 8 | (_Unwind_Exception_Class) 'N')
- << 8 | (_Unwind_Exception_Class) 'U')
-@@ -181,6 +182,9 @@ const _Unwind_Exception_Class __gxx_exce
- << 8 | (_Unwind_Exception_Class) '+')
- << 8 | (_Unwind_Exception_Class) '+')
- << 8 | (_Unwind_Exception_Class) '\0');
-+#else
-+= "GNUC++";
-+#endif
-
- // GNU C++ personality routine, Version 0.
- extern "C" _Unwind_Reason_Code __gxx_personality_v0