aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/util-linux/patches/001-no-printf-alloc.patch
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2016-04-17 15:16:12 +0000
committerHauke Mehrtens <hauke@openwrt.org>2016-04-17 15:16:12 +0000
commit11b8252d157f44c2b366e47159d98b293a72bf0e (patch)
tree25ed6330fb61539239b3e91469163eee40599028 /package/utils/util-linux/patches/001-no-printf-alloc.patch
parenteb15253d46bcfa07ab2310ed1e76370de578db85 (diff)
downloadmaster-187ad058-11b8252d157f44c2b366e47159d98b293a72bf0e.tar.gz
master-187ad058-11b8252d157f44c2b366e47159d98b293a72bf0e.tar.bz2
master-187ad058-11b8252d157f44c2b366e47159d98b293a72bf0e.zip
util-linux: update to version 2.28
The following patches were merged upstream: * 0001-switch_root-improve-statfs-f_type-portability.patch * 0002-lib-colors-use-static-buffers-when-parse-scheme.patch * 002-mkostemp.patch The following patch is not needed any more because all libc implementations support alloc in sscanf: * 001-no-printf-alloc.patch Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@49191 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/utils/util-linux/patches/001-no-printf-alloc.patch')
-rw-r--r--package/utils/util-linux/patches/001-no-printf-alloc.patch104
1 files changed, 0 insertions, 104 deletions
diff --git a/package/utils/util-linux/patches/001-no-printf-alloc.patch b/package/utils/util-linux/patches/001-no-printf-alloc.patch
deleted file mode 100644
index ad9eef0959..0000000000
--- a/package/utils/util-linux/patches/001-no-printf-alloc.patch
+++ /dev/null
@@ -1,104 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -798,7 +798,6 @@ AC_ARG_ENABLE([libmount],
- )
- UL_BUILD_INIT([libmount])
- UL_REQUIRES_BUILD([libmount], [libblkid])
--UL_REQUIRES_HAVE([libmount], [scanf_alloc_modifier], [scanf string alloc modifier])
- AM_CONDITIONAL([BUILD_LIBMOUNT], [test "x$build_libmount" = xyes])
- AM_CONDITIONAL([BUILD_LIBMOUNT_TESTS], [test "x$build_libmount" = xyes -a "x$enable_static" = xyes])
-
---- a/libmount/src/tab_parse.c
-+++ b/libmount/src/tab_parse.c
-@@ -22,6 +22,10 @@
- #include "pathnames.h"
- #include "strutils.h"
-
-+#ifndef HAVE_SCANF_MS_MODIFIER
-+# define UL_SCNsA "%s"
-+#endif
-+
- static int next_number(char **s, int *num)
- {
- char *end = NULL;
-@@ -52,16 +56,31 @@ static int mnt_parse_table_line(struct l
- int rc, n = 0, xrc;
- char *src = NULL, *fstype = NULL, *optstr = NULL;
-
-+#ifndef HAVE_SCANF_MS_MODIFIER
-+ size_t len = strlen(s) + 1;
-+ src = malloc(len);
-+ fstype = malloc(len);
-+ fs->target = malloc(len);
-+ optstr = malloc(len);
-+#endif
-+
- rc = sscanf(s, UL_SCNsA" " /* (1) source */
- UL_SCNsA" " /* (2) target */
- UL_SCNsA" " /* (3) FS type */
- UL_SCNsA" " /* (4) options */
- "%n", /* byte count */
-
-+#ifdef HAVE_SCANF_MS_MODIFIER
- &src,
- &fs->target,
- &fstype,
- &optstr,
-+#else
-+ src,
-+ fs->target,
-+ fstype,
-+ optstr,
-+#endif
- &n);
- xrc = rc;
-
-@@ -127,6 +146,16 @@ static int mnt_parse_mountinfo_line(stru
- unsigned int maj, min;
- char *fstype = NULL, *src = NULL, *p;
-
-+#ifndef HAVE_SCANF_MS_MODIFIER
-+ size_t len = strlen(s) + 1;
-+ fs->root = malloc(len);
-+ fs->target = malloc(len);
-+ fs->vfs_optstr = malloc(len);
-+ fs->fs_optstr = malloc(len);
-+ fstype = malloc(len);
-+ src = malloc(len);
-+#endif
-+
- rc = sscanf(s, "%d " /* (1) id */
- "%d " /* (2) parent */
- "%u:%u " /* (3) maj:min */
-@@ -138,9 +167,15 @@ static int mnt_parse_mountinfo_line(stru
- &fs->id,
- &fs->parent,
- &maj, &min,
-+#ifdef HAVE_SCANF_MS_MODIFIER
- &fs->root,
- &fs->target,
- &fs->vfs_optstr,
-+#else
-+ fs->root,
-+ fs->target,
-+ fs->vfs_optstr,
-+#endif
- &end);
-
- if (rc >= 7 && end > 0)
-@@ -160,9 +195,15 @@ static int mnt_parse_mountinfo_line(stru
- UL_SCNsA" " /* (9) source */
- UL_SCNsA, /* (10) fs options (fs specific) */
-
-+#ifdef HAVE_SCANF_MS_MODIFIER
- &fstype,
- &src,
- &fs->fs_optstr);
-+#else
-+ fstype,
-+ src,
-+ fs->fs_optstr);
-+#endif
-
- if (rc >= 10) {
- size_t sz;