aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-12-09 17:18:41 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-12-09 17:18:41 +0000
commit083164fef395630859df98fb61028367dd5daaac (patch)
tree9a703d61feec43e1d1c07f1281d8be597fbaf34a /package
parent3596666f1aff71ac916e9a9bdb4465276254ab72 (diff)
downloadmaster-187ad058-083164fef395630859df98fb61028367dd5daaac.tar.gz
master-187ad058-083164fef395630859df98fb61028367dd5daaac.tar.bz2
master-187ad058-083164fef395630859df98fb61028367dd5daaac.zip
[package] kernel: fix raid module packaging on newer kernels (#8384)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24394 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/block.mk11
1 files changed, 10 insertions, 1 deletions
diff --git a/package/kernel/modules/block.mk b/package/kernel/modules/block.mk
index 8513f3d82e..6d36cde621 100644
--- a/package/kernel/modules/block.mk
+++ b/package/kernel/modules/block.mk
@@ -308,8 +308,17 @@ $(call KernelPackage/md/Depends,)
$(LINUX_DIR)/crypto/async_tx/async_xor.$(LINUX_KMOD_SUFFIX) \
$(LINUX_DIR)/crypto/async_tx/async_pq.$(LINUX_KMOD_SUFFIX) \
$(LINUX_DIR)/crypto/async_tx/async_raid6_recov.$(LINUX_KMOD_SUFFIX) \
- $(LINUX_DIR)/drivers/md/raid6_pq.$(LINUX_KMOD_SUFFIX) \
$(LINUX_DIR)/drivers/md/raid456.$(LINUX_KMOD_SUFFIX)
+ # Additional files with kernel-dependent locations or presence
+ # For Linux >= 2.6.36
+ ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.36)), 1)
+ FILES+= \
+ $(LINUX_DIR)/lib/raid6/raid6_pq.$(LINUX_KMOD_SUFFIX)
+ # For Linux < 2.6.36
+ else
+ FILES+= \
+ $(LINUX_DIR)/drivers/md/raid6_pq.$(LINUX_KMOD_SUFFIX)
+ endif
AUTOLOAD:=$(call AutoLoad,28, xor async_tx async_memcpy async_xor raid6_pq async_pq async_raid6_recov raid456)
endef