aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-10-06 04:52:51 +0000
committerJohn Crispin <blogic@openwrt.org>2014-10-06 04:52:51 +0000
commit09039308fa7372aa94189e8c9b7b8715b07655b8 (patch)
treec2288352bf450792db006986c101df025d123949 /package
parent6e8e2303cb786cb199fbf4d6fff130ea5cbad4ba (diff)
downloadmaster-187ad058-09039308fa7372aa94189e8c9b7b8715b07655b8.tar.gz
master-187ad058-09039308fa7372aa94189e8c9b7b8715b07655b8.tar.bz2
master-187ad058-09039308fa7372aa94189e8c9b7b8715b07655b8.zip
kernel: add rtc-ds1307 module support
Signed-off-by: Michael Heimpold <mhei@heimpold.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42791 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/other.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index d56bb5076f..58aae3ce58 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -505,6 +505,24 @@ endef
$(eval $(call KernelPackage,pwm-gpio))
+define KernelPackage/rtc-ds1307
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Dallas/Maxim DS1307 (and compatible) RTC support
+ $(call AddDepends/rtc)
+ DEPENDS+=+kmod-i2c-core
+ KCONFIG:=CONFIG_RTC_DRV_DS1307
+ FILES:=$(LINUX_DIR)/drivers/rtc/rtc-ds1307.ko
+ AUTOLOAD:=$(call AutoProbe,rtc-ds1307)
+endef
+
+define KernelPackage/rtc-ds1307/description
+ Kernel module for Dallas/Maxim DS1307/DS1337/DS1338/DS1340/DS1388/DS3231,
+ Epson RX-8025 and various other compatible RTC chips connected via I2C.
+endef
+
+$(eval $(call KernelPackage,rtc-ds1307))
+
+
define KernelPackage/rtc-ds1672
SUBMENU:=$(OTHER_MENU)
TITLE:=Dallas/Maxim DS1672 RTC support