aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-01-17 22:12:05 +0000
committerJohn Crispin <blogic@openwrt.org>2014-01-17 22:12:05 +0000
commit1f0ac4101be71a954d16285163bebc85ad2f1d4d (patch)
tree1909e5d013f5f16e45c90e0c6d837b9a0e0ad7dd /package
parent9743a51ce5c642ca581bdf4c3df3d09a1288282c (diff)
downloadmaster-187ad058-1f0ac4101be71a954d16285163bebc85ad2f1d4d.tar.gz
master-187ad058-1f0ac4101be71a954d16285163bebc85ad2f1d4d.tar.bz2
master-187ad058-1f0ac4101be71a954d16285163bebc85ad2f1d4d.zip
sysupgrade: do not kill any processes in failsafe
sysugrade killed the lock causing failsafe to stop Signed-off-by: Alexander Couzens <lynxis@fe80.eu> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39318 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/base-files/Makefile2
-rwxr-xr-xpackage/base-files/files/sbin/sysupgrade8
2 files changed, 6 insertions, 4 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 0160e41f88..d6c59384ee 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
include $(INCLUDE_DIR)/version.mk
PKG_NAME:=base-files
-PKG_RELEASE:=149
+PKG_RELEASE:=150
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
PKG_BUILD_DEPENDS:=opkg/host
diff --git a/package/base-files/files/sbin/sysupgrade b/package/base-files/files/sbin/sysupgrade
index 56e9a92424..e6588bffcf 100755
--- a/package/base-files/files/sbin/sysupgrade
+++ b/package/base-files/files/sbin/sysupgrade
@@ -210,9 +210,11 @@ run_hooks "" $sysupgrade_pre_upgrade
ubus call system upgrade
touch /tmp/sysupgrade
-kill_remaining TERM
-sleep 3
-kill_remaining KILL
+if [ ! -f /tmp/failsafe ] ; then
+ kill_remaining TERM
+ sleep 3
+ kill_remaining KILL
+fi
if [ -n "$(rootfs_type)" ]; then
v "Switching to ramdisk..."