aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-06-10 10:22:18 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-06-10 10:22:18 +0000
commit233e157fc5bf0d65eac2a5900c1c27e160b42830 (patch)
treee7827ff764aa69f46c993afa91afb3bd04f96fd7 /package
parent08bd449e86479b6d2de5a00dc9314047f022d80e (diff)
downloadmaster-187ad058-233e157fc5bf0d65eac2a5900c1c27e160b42830.tar.gz
master-187ad058-233e157fc5bf0d65eac2a5900c1c27e160b42830.tar.bz2
master-187ad058-233e157fc5bf0d65eac2a5900c1c27e160b42830.zip
strace: move to trunk, add myself as a maintainer
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41097 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/devel/strace/Makefile50
1 files changed, 50 insertions, 0 deletions
diff --git a/package/devel/strace/Makefile b/package/devel/strace/Makefile
new file mode 100644
index 0000000000..4c29d69cda
--- /dev/null
+++ b/package/devel/strace/Makefile
@@ -0,0 +1,50 @@
+#
+# Copyright (C) 2006-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=strace
+
+PKG_VERSION:=4.8
+PKG_RELEASE:=1
+PKG_MD5SUM:=c575ef43829586801f514fd91bfe7575
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=@SF/$(PKG_NAME)
+
+PKG_LICENSE:=BSD-3c
+PKG_LICENSE_FILES:=COPYRIGHT
+
+PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
+
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/strace
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=System call tracer
+ URL:=http://strace.sourceforge.net/
+endef
+
+define Package/strace/description
+A useful diagnostic, instructional, and debugging tool. Allows you to track what
+system calls a program makes while it is running.
+endef
+
+MAKE_FLAGS := \
+ CCOPT="$(TARGET_CFLAGS)"
+
+define Package/strace/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/strace $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,strace))