aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorMichael Büsch <mb@bu3sch.de>2009-02-10 16:55:38 +0000
committerMichael Büsch <mb@bu3sch.de>2009-02-10 16:55:38 +0000
commit317bf035162f73b469bd548be571f7bd0b95e816 (patch)
tree9a720feb533791e187439fa9c19c33ebb988a27d /package
parentf4937f60c99fa61ee13644a93b46317a1e08a1b6 (diff)
downloadmaster-187ad058-317bf035162f73b469bd548be571f7bd0b95e816.tar.gz
master-187ad058-317bf035162f73b469bd548be571f7bd0b95e816.tar.bz2
master-187ad058-317bf035162f73b469bd548be571f7bd0b95e816.zip
Deprecate the old SPI-GPIO driver.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14464 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/other.mk14
-rw-r--r--package/mmc_over_gpio/Makefile2
-rw-r--r--package/wrt55agv2-spidevs/Makefile2
-rw-r--r--package/wrt55agv2-spidevs/src/wrt55agv2_spidevs.c2
4 files changed, 10 insertions, 10 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index fd1093660a..063096fe9b 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -690,20 +690,20 @@ endef
$(eval $(call KernelPackage,spi-bitbang))
-define KernelPackage/spi-gpio
+define KernelPackage/spi-gpio-old
SUBMENU:=$(OTHER_MENU)
- TITLE:=GPIO based bitbanging SPI controller
+ TITLE:=Old GPIO based bitbanging SPI controller (DEPRECATED)
DEPENDS:=@GPIO_SUPPORT +kmod-spi-bitbang
- KCONFIG:=CONFIG_SPI_GPIO
- FILES:=$(LINUX_DIR)/drivers/spi/spi_gpio.$(LINUX_KMOD_SUFFIX)
- AUTOLOAD:=$(call AutoLoad,92,spi_gpio)
+ KCONFIG:=CONFIG_SPI_GPIO_OLD
+ FILES:=$(LINUX_DIR)/drivers/spi/spi_gpio_old.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,92,spi_gpio_old)
endef
-define KernelPackage/spi-gpio/description
+define KernelPackage/spi-gpio-old/description
This package contains the GPIO based bitbanging SPI controller driver
endef
-$(eval $(call KernelPackage,spi-gpio))
+$(eval $(call KernelPackage,spi-gpio-old))
define KernelPackage/spi-dev
SUBMENU:=$(OTHER_MENU)
diff --git a/package/mmc_over_gpio/Makefile b/package/mmc_over_gpio/Makefile
index a3d1787658..cd911c6f55 100644
--- a/package/mmc_over_gpio/Makefile
+++ b/package/mmc_over_gpio/Makefile
@@ -15,7 +15,7 @@ include $(INCLUDE_DIR)/package.mk
define KernelPackage/mmc-over-gpio
SUBMENU:=Other modules
- DEPENDS:=@GPIO_SUPPORT +kmod-mmc-spi +kmod-spi-gpio
+ DEPENDS:=@GPIO_SUPPORT +kmod-mmc-spi +kmod-spi-gpio-old
KCONFIG:=CONFIG_GPIOMMC CONFIG_CONFIGFS_FS=y
TITLE:=MMC/SD card over GPIO support
FILES:=$(LINUX_DIR)/drivers/mmc/host/gpiommc.$(LINUX_KMOD_SUFFIX)
diff --git a/package/wrt55agv2-spidevs/Makefile b/package/wrt55agv2-spidevs/Makefile
index fa9b1c07ab..c6c85dab42 100644
--- a/package/wrt55agv2-spidevs/Makefile
+++ b/package/wrt55agv2-spidevs/Makefile
@@ -16,7 +16,7 @@ include $(INCLUDE_DIR)/package.mk
define KernelPackage/wrt55agv2-spidevs
SUBMENU:=Other modules
TITLE:=WRT55AG v2 SPI devices support
- DEPENDS:=@LINUX_2_6 @TARGET_atheros +kmod-spi-gpio +kmod-spi-ks8995
+ DEPENDS:=@LINUX_2_6 @TARGET_atheros +kmod-spi-gpio-old +kmod-spi-ks8995
FILES:=$(PKG_BUILD_DIR)/wrt55agv2_spidevs.$(LINUX_KMOD_SUFFIX)
endef
diff --git a/package/wrt55agv2-spidevs/src/wrt55agv2_spidevs.c b/package/wrt55agv2-spidevs/src/wrt55agv2_spidevs.c
index b1aec4f2e1..9d127dd915 100644
--- a/package/wrt55agv2-spidevs/src/wrt55agv2_spidevs.c
+++ b/package/wrt55agv2-spidevs/src/wrt55agv2_spidevs.c
@@ -12,7 +12,7 @@
*/
#include <linux/platform_device.h>
-#include <linux/spi/spi_gpio.h>
+#include <linux/spi/spi_gpio_old.h>
#define DRV_NAME "wrt55agv2-spidevs"
#define DRV_DESC "SPI driver for the WRT55AG v2 board"