aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-05-19 21:39:10 +0000
committerNicolas Thill <nico@openwrt.org>2010-05-19 21:39:10 +0000
commit4ec94ac262098a871c0bedc40799153217722f38 (patch)
treeab1f861d25e66df8e432c3685542097020b24786 /package
parent2d4ba544c5e949620c3a1ee3518439a01d73b701 (diff)
downloadmaster-187ad058-4ec94ac262098a871c0bedc40799153217722f38.tar.gz
master-187ad058-4ec94ac262098a871c0bedc40799153217722f38.tar.bz2
master-187ad058-4ec94ac262098a871c0bedc40799153217722f38.zip
package/busybox: add upstream udhcp hostname truncation fix, bump release number
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21510 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/busybox/Makefile2
-rw-r--r--package/busybox/patches/000-upstream-dhcpd.patch11
2 files changed, 12 insertions, 1 deletions
diff --git a/package/busybox/Makefile b/package/busybox/Makefile
index 3b93a0575d..60daf8d7d4 100644
--- a/package/busybox/Makefile
+++ b/package/busybox/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=busybox
PKG_VERSION:=1.16.1
-PKG_RELEASE:=5
+PKG_RELEASE:=6
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://www.busybox.net/downloads \
diff --git a/package/busybox/patches/000-upstream-dhcpd.patch b/package/busybox/patches/000-upstream-dhcpd.patch
new file mode 100644
index 0000000000..eef33f80de
--- /dev/null
+++ b/package/busybox/patches/000-upstream-dhcpd.patch
@@ -0,0 +1,11 @@
+--- a/networking/udhcp/leases.c
++++ b/networking/udhcp/leases.c
+@@ -64,6 +64,8 @@ struct dyn_lease* FAST_FUNC add_lease(
+ oldest->hostname[0] = '\0';
+ if (hostname) {
+ char *p;
++
++ hostname_len++; /* include NUL */
+ if (hostname_len > sizeof(oldest->hostname))
+ hostname_len = sizeof(oldest->hostname);
+ p = safe_strncpy(oldest->hostname, hostname, hostname_len);