aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-06-11 12:59:45 +0000
committerJohn Crispin <blogic@openwrt.org>2014-06-11 12:59:45 +0000
commit52b25de084a159b5cf14d4b595966e0d7a5dcbd8 (patch)
tree9e8480ceb4882af013f460486191663b59594ad2 /package
parentf1c0ad03b70dc3b294d67d9af0b150660ca8f269 (diff)
downloadmaster-187ad058-52b25de084a159b5cf14d4b595966e0d7a5dcbd8.tar.gz
master-187ad058-52b25de084a159b5cf14d4b595966e0d7a5dcbd8.tar.bz2
master-187ad058-52b25de084a159b5cf14d4b595966e0d7a5dcbd8.zip
fstools: the ubi flash tool is obselete now
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41128 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/system/fstools/Makefile15
1 files changed, 1 insertions, 14 deletions
diff --git a/package/system/fstools/Makefile b/package/system/fstools/Makefile
index b10f105a74..08b3be478f 100644
--- a/package/system/fstools/Makefile
+++ b/package/system/fstools/Makefile
@@ -32,16 +32,10 @@ TARGET_LDFLAGS += $(if $(CONFIG_USE_EGLIBC),-lrt)
define Package/fstools
SECTION:=base
CATEGORY:=Base system
- DEPENDS:=+ubox +USE_EGLIBC:librt
+ DEPENDS:=+ubox +USE_EGLIBC:librt +NAND_SUPPORT:ubi-utils
TITLE:=OpenWrt filesystem tools
endef
-define Package/ubi-flash
- SECTION:=base
- CATEGORY:=Base system
- TITLE:=OpenWrt ubi flashing tool
-endef
-
define Package/block-mount
SECTION:=base
CATEGORY:=Base system
@@ -58,12 +52,6 @@ define Package/fstools/install
ln -s /sbin/jffs2reset $(1)/sbin/jffs2mark
endef
-define Package/ubi-flash/install
- $(INSTALL_DIR) $(1)/sbin $(1)/lib
-
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ubi $(1)/sbin/
-endef
-
define Package/block-mount/install
$(INSTALL_DIR) $(1)/sbin $(1)/lib $(1)/usr/sbin $(1)/etc/hotplug.d/block $(1)/etc/init.d/ $(1)/etc/uci-defaults/
@@ -86,5 +74,4 @@ define Build/InstallDev
endef
$(eval $(call BuildPackage,fstools))
-$(eval $(call BuildPackage,ubi-flash))
$(eval $(call BuildPackage,block-mount))