aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-01-08 02:18:45 +0000
committerNicolas Thill <nico@openwrt.org>2009-01-08 02:18:45 +0000
commit59d0bab8e7a69d46481e06e9b019a1f39ab7f8b1 (patch)
tree1c7490530dfe1020202485241ac8022f23a6577c /package
parent3b75e47f8f0d1db7575f0824f7a2469e2e8af7cf (diff)
downloadmaster-187ad058-59d0bab8e7a69d46481e06e9b019a1f39ab7f8b1.tar.gz
master-187ad058-59d0bab8e7a69d46481e06e9b019a1f39ab7f8b1.tar.bz2
master-187ad058-59d0bab8e7a69d46481e06e9b019a1f39ab7f8b1.zip
temp fix for iptables build failure after [13931]
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13932 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/iptables/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/iptables/Makefile b/package/iptables/Makefile
index 43a3cdf515..55ca0b370f 100644
--- a/package/iptables/Makefile
+++ b/package/iptables/Makefile
@@ -256,7 +256,10 @@ endif
TARGET_CPPFLAGS := -I$(PKG_BUILD_DIR)/include $(TARGET_CPPFLAGS)
TARGET_CFLAGS += $(FPIC)
-CONFIGURE_ARGS += --enable-devel --with-xtlibdir=/usr/lib/iptables
+CONFIGURE_ARGS += \
+ --enable-devel \
+ --with-kernel="$(LINUX_DIR)" \
+ --with-xtlibdir=/usr/lib/iptables
define Build/Compile
mkdir -p $(PKG_INSTALL_DIR)