aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2011-07-23 11:17:36 +0000
committerHauke Mehrtens <hauke@openwrt.org>2011-07-23 11:17:36 +0000
commit9521774338779e00cd91aa963c65becdd171aae1 (patch)
tree03e164f641760da2c3aca2ea5e60316d7ef647b6 /package
parent31f52e211e330a9d8421d96a03b529dafc43a0e3 (diff)
downloadmaster-187ad058-9521774338779e00cd91aa963c65becdd171aae1.tar.gz
master-187ad058-9521774338779e00cd91aa963c65becdd171aae1.tar.bz2
master-187ad058-9521774338779e00cd91aa963c65becdd171aae1.zip
kernel: add bcma package
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27732 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/other.mk23
1 files changed, 23 insertions, 0 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index b6339a6844..97b8877002 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -548,6 +548,29 @@ endef
$(eval $(call KernelPackage,ssb))
+define KernelPackage/bcma
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=BCMA support
+ DEPENDS:=@PCI_SUPPORT @!TARGET_brcm47xx
+ KCONFIG:=\
+ CONFIG_BCMA \
+ CONFIG_BCMA_POSSIBLE=y \
+ CONFIG_BCMA_BLOCKIO=y \
+ CONFIG_BCMA_HOST_PCI_POSSIBLE=y \
+ CONFIG_BCMA_HOST_PCI=y \
+ CONFIG_BCMA_DRIVER_PCI_HOSTMODE=n \
+ CONFIG_BCMA_DEBUG=n
+ FILES:=$(LINUX_DIR)/drivers/bcma/bcma.ko
+ AUTOLOAD:=$(call AutoLoad,29,bcma)
+endef
+
+define KernelPackage/bcma/description
+ Bus driver for Broadcom specific Advanced Microcontroller Bus Architecture.
+endef
+
+$(eval $(call KernelPackage,bcma))
+
+
define KernelPackage/wdt-geode
SUBMENU:=$(OTHER_MENU)
TITLE:=Geode/LX Watchdog timer