aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2011-11-13 12:09:34 +0000
committerJohn Crispin <blogic@openwrt.org>2011-11-13 12:09:34 +0000
commitc517d3fe7f1284b44d4b02772d2348a3f0fd1390 (patch)
treed5ce6a6cc6ca8e84491b53627b7ea784b42c6637 /package
parent3e8f76c6c1d54f8be89c37b4de44374683182a58 (diff)
downloadmaster-187ad058-c517d3fe7f1284b44d4b02772d2348a3f0fd1390.tar.gz
master-187ad058-c517d3fe7f1284b44d4b02772d2348a3f0fd1390.tar.bz2
master-187ad058-c517d3fe7f1284b44d4b02772d2348a3f0fd1390.zip
uboot-lantiq: not all configs were using lzma for compression, add gigaset ramboot image
Signed-off-by: Andrej Vlašić <andrej.vlasic0@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29019 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/uboot-lantiq/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/package/uboot-lantiq/Makefile b/package/uboot-lantiq/Makefile
index 44a0eec8aa..87f07f37b8 100644
--- a/package/uboot-lantiq/Makefile
+++ b/package/uboot-lantiq/Makefile
@@ -37,16 +37,19 @@ define Package/uboot-lantiq-template
endef
#Lantiq
-Package/uboot-lantiq-easy50712_DDR166M=$(call Package/uboot-lantiq-template,easy50712_DDR166M,NOR)
+Package/uboot-lantiq-easy50712_DDR166M_flash=$(call Package/uboot-lantiq-template,easy50712_DDR166M_flash,NOR)
Package/uboot-lantiq-easy50712_DDR166M_ramboot=$(call Package/uboot-lantiq-template,easy50712_DDR166M_ramboot,RAM)
-Package/uboot-lantiq-easy50812_DDR166M=$(call Package/uboot-lantiq-template,easy50812_DDR166M,NOR)
+Package/uboot-lantiq-easy50812_DDR166M_flash=$(call Package/uboot-lantiq-template,easy50812_DDR166M_flash,NOR)
Package/uboot-lantiq-easy50812_DDR166M_ramboot=$(call Package/uboot-lantiq-template,easy50812_DDR166M_ramboot,RAM)
DDR_CONFIG_easy50712_DDR166M_ramboot:=easy50712_DDR166M
DDR_CONFIG_easy50812_DDR166M_ramboot:=easy50812
#Siemens
-Package/uboot-lantiq-gigaSX76X_DDRsamsung166=$(call Package/uboot-lantiq-template,gigaSX76X_DDRsamsung166,NOR)
+Package/uboot-lantiq-gigaSX76X_DDRsamsung166_flash=$(call Package/uboot-lantiq-template,gigaSX76X_DDRsamsung166_flash,NOR)
+Package/uboot-lantiq-gigaSX76X_DDRsamsung166_ramboot=$(call Package/uboot-lantiq-template,gigaSX76X_DDRsamsung166_ramboot,RAM)
+
+DDR_CONFIG_gigaSX76X_DDRsamsung166_ramboot:=easy50712_DDR166M
#Arcadyan
Package/uboot-lantiq-arv3527P_flash=$(call Package/uboot-lantiq-template,arv3527P_flash,NOR)
@@ -140,11 +143,12 @@ ifneq ($(findstring ramboot,$(BUILD_VARIANT)),)
endif
endef
-$(eval $(call BuildPackage,uboot-lantiq-easy50712_DDR166M))
+$(eval $(call BuildPackage,uboot-lantiq-easy50712_DDR166M_flash))
$(eval $(call BuildPackage,uboot-lantiq-easy50712_DDR166M_ramboot))
-$(eval $(call BuildPackage,uboot-lantiq-easy50812_DDR166M))
+$(eval $(call BuildPackage,uboot-lantiq-easy50812_DDR166M_flash))
$(eval $(call BuildPackage,uboot-lantiq-easy50812_DDR166M_ramboot))
-$(eval $(call BuildPackage,uboot-lantiq-gigaSX76X_DDRsamsung166))
+$(eval $(call BuildPackage,uboot-lantiq-gigaSX76X_DDRsamsung166_flash))
+$(eval $(call BuildPackage,uboot-lantiq-gigaSX76X_DDRsamsung166_ramboot))
#$(eval $(call BuildPackage,uboot-lantiq-arv3527P_flash))
#$(eval $(call BuildPackage,uboot-lantiq-arv3527P_brnboot))
#$(eval $(call BuildPackage,uboot-lantiq-arv3527P_ramboot))