aboutsummaryrefslogtreecommitdiffstats
path: root/target/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-09-05 00:45:03 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-09-05 00:45:03 +0000
commitb4adfc747512767e631749adc8cba5bfd9a309eb (patch)
tree37cd83e064df1603b31f09bd53048496c73360e9 /target/image
parent3b866fdd8572f6d62ab67f8f0fccc8df95cbdbc0 (diff)
downloadmaster-187ad058-b4adfc747512767e631749adc8cba5bfd9a309eb.tar.gz
master-187ad058-b4adfc747512767e631749adc8cba5bfd9a309eb.tar.bz2
master-187ad058-b4adfc747512767e631749adc8cba5bfd9a309eb.zip
enable squashfs in the magicbox kernel (not used yet), magicbox build now no longer broken (images work well with jffs2)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4753 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/image')
-rw-r--r--target/image/magicbox/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/target/image/magicbox/Makefile b/target/image/magicbox/Makefile
index f0b19b1d23..10f71df2a9 100644
--- a/target/image/magicbox/Makefile
+++ b/target/image/magicbox/Makefile
@@ -22,11 +22,17 @@ define Image/Build
endef
define Image/Build/jffs2-64k
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img bs=65536 conv=sync
+ ( \
+ dd if=$(LINUX_DIR)/arch/ppc/boot/images/uImage bs=65536 conv=sync; \
+ dd if=$(KDIR)/root.$(1) bs=65536 conv=sync; \
+ ) > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
endef
-define Image/Build/jffs2-128k
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img bs=131072 conv=sync
-endef
+#define Image/Build/jffs2-128k
+# ( \
+# dd if=$(LINUX_DIR)/arch/ppc/boot/images/uImage bs=131072 conv=sync; \
+# dd if=$(KDIR)/root.$(1) bs=131072 conv=sync; \
+# ) > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
+#endef
$(eval $(call BuildImage))