aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar7/patches-3.10/320-ac49x-mtd-partitions.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2013-10-12 10:50:44 +0000
committerJonas Gorski <jogo@openwrt.org>2013-10-12 10:50:44 +0000
commit2b6cea4a6e3b71dbfc8ae51775310933aae796b6 (patch)
tree904dffa29a1d5e05570e553fd99318227240fdd0 /target/linux/ar7/patches-3.10/320-ac49x-mtd-partitions.patch
parent33018b3e4563d074d27312a92e34b3f8e05b1b73 (diff)
downloadmaster-187ad058-2b6cea4a6e3b71dbfc8ae51775310933aae796b6.tar.gz
master-187ad058-2b6cea4a6e3b71dbfc8ae51775310933aae796b6.tar.bz2
master-187ad058-2b6cea4a6e3b71dbfc8ae51775310933aae796b6.zip
ar7: add support for linux 3.10 and switch to it
Run tested on WAG354Gv2. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38369 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar7/patches-3.10/320-ac49x-mtd-partitions.patch')
-rw-r--r--target/linux/ar7/patches-3.10/320-ac49x-mtd-partitions.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/target/linux/ar7/patches-3.10/320-ac49x-mtd-partitions.patch b/target/linux/ar7/patches-3.10/320-ac49x-mtd-partitions.patch
new file mode 100644
index 0000000000..3bccd3e187
--- /dev/null
+++ b/target/linux/ar7/patches-3.10/320-ac49x-mtd-partitions.patch
@@ -0,0 +1,35 @@
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -188,6 +188,11 @@ config MTD_OF_PARTS
+ the partition map from the children of the flash node,
+ as described in Documentation/devicetree/booting-without-of.txt.
+
++config MTD_AC49X_PARTS
++ tristate "AudioCodes AC49X partitioning support"
++ ---help---
++ AudioCodes AC49X partitioning support
++
+ config MTD_AR7_PARTS
+ tristate "TI AR7 partitioning support"
+ ---help---
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -14,6 +14,7 @@ mtd-$(CONFIG_MTD_SPLIT_UIMAGE_FW) += mtd
+ obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
+ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
+ obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
++obj-$(CONFIG_MTD_AC49X_PARTS) += ac49xpart.o
+ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
+ obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o titanpart.o
+ obj-$(CONFIG_MTD_BCM63XX_PARTS) += bcm63xxpart.o
+--- a/arch/mips/ar7/platform.c
++++ b/arch/mips/ar7/platform.c
+@@ -202,7 +202,7 @@ static struct resource physmap_flash_res
+ .end = 0x11ffffff,
+ };
+
+-static const char *ar7_probe_types[] = { "ar7part", NULL };
++static const char *ar7_probe_types[] = { "ac49xpart", "ar7part", NULL };
+
+ static struct physmap_flash_data physmap_flash_data = {
+ .width = 2,