aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-07-07 13:01:48 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-07-07 13:01:48 +0000
commite9e6aeacc0072399742464d9126c93bba9cee9ef (patch)
tree09089f20f3c591fc33aac2aec5f64e87ad315fb6 /target/linux/ar71xx/generic
parent27aea2ff2da64dda645feeb60a9315d99b7824e5 (diff)
downloadmaster-187ad058-e9e6aeacc0072399742464d9126c93bba9cee9ef.tar.gz
master-187ad058-e9e6aeacc0072399742464d9126c93bba9cee9ef.tar.bz2
master-187ad058-e9e6aeacc0072399742464d9126c93bba9cee9ef.zip
ar71xx: add separate profiles for the AP121 and AP121-MINI boards
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27522 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/generic')
-rw-r--r--target/linux/ar71xx/generic/profiles/atheros.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/atheros.mk b/target/linux/ar71xx/generic/profiles/atheros.mk
index 60b109accf..36c918b4b0 100644
--- a/target/linux/ar71xx/generic/profiles/atheros.mk
+++ b/target/linux/ar71xx/generic/profiles/atheros.mk
@@ -5,6 +5,28 @@
# See /LICENSE for more information.
#
+define Profile/AP121
+ NAME:=Atheros AP121 reference board
+ PACKAGES:=wpad-mini kmod-ath9k kmod-usb-core kmod-usb2
+endef
+
+define Profile/AP121/Description
+ Package set optimized for the Atheros AP121 reference board.
+endef
+
+$(eval $(call Profile,AP121))
+
+define Profile/AP121MINI
+ NAME:=Atheros AP121-MINI reference board
+ PACKAGES:=wpad-mini kmod-ath9k
+endef
+
+define Profile/AP121MINI/Description
+ Package set optimized for the Atheros AP121-MINI reference board.
+endef
+
+$(eval $(call Profile,AP121MINI))
+
define Profile/AP81
NAME:=Atheros AP81 reference board
PACKAGES:=wpad-mini kmod-ath9k kmod-usb-core kmod-usb2