aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-06-18 18:21:05 +0000
committerJohn Crispin <blogic@openwrt.org>2015-06-18 18:21:05 +0000
commit6f137449e8ac99312a1d097b8208530fe2136923 (patch)
treee8da496bac55c7a678d1ebd5ded5d3f757205fa6 /target/linux/ar71xx/image
parent3146134687cbd0a49243d623063b1563013c12a7 (diff)
downloadmaster-187ad058-6f137449e8ac99312a1d097b8208530fe2136923.tar.gz
master-187ad058-6f137449e8ac99312a1d097b8208530fe2136923.tar.bz2
master-187ad058-6f137449e8ac99312a1d097b8208530fe2136923.zip
ar71xx: Add Support for the Bitmain Antminer S1
This patch adds support for the Bitmain Antminer S1 Cryptocurrency Miner http://wiki.openwrt.org/toh/bitmain/s1 Signed-off-by: L. D. Pinney <ldpinney@gmail.com> Acked-by: James Hilliard <james.hilliard1@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46044 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 0e46194e75..5a82b7caf0 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -330,6 +330,14 @@ define Device/archer-c7-v2
endef
TARGET_DEVICES += archer-c5 archer-c7-v1 archer-c7-v2
+define Device/antminer-s1
+ $(Device/tplink-8mlzma)
+ BOARDNAME := ANTMINER-S1
+ DEVICE_PROFILE := ANTMINER_S1
+ TPLINK_HWID := 0x04440001
+ CONSOLE := ttyATH0,115200
+endef
+
define Device/el-m150
$(Device/tplink-8mlzma)
BOARDNAME := EL-M150
@@ -345,7 +353,7 @@ define Device/el-mini
TPLINK_HWID := 0x01530001
CONSOLE := ttyATH0,115200
endef
-TARGET_DEVICES += el-m150 el-mini
+TARGET_DEVICES += antminer-s1 el-m150 el-mini
define Device/gl-inet-6408A-v1
$(Device/tplink-8mlzma)