aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.31/201-ap83_spi_controller.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-08-24 19:29:50 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-08-24 19:29:50 +0000
commit392c43fc2cb45abc6468b886ad6d4427167efffa (patch)
treef8c70e746cad812e42f615d55e4996343e373b1a /target/linux/ar71xx/patches-2.6.31/201-ap83_spi_controller.patch
parentba80b7417b3c32a8570c759476f1fe2029366467 (diff)
downloadmaster-187ad058-392c43fc2cb45abc6468b886ad6d4427167efffa.tar.gz
master-187ad058-392c43fc2cb45abc6468b886ad6d4427167efffa.tar.bz2
master-187ad058-392c43fc2cb45abc6468b886ad6d4427167efffa.zip
[ar71xx] add patches for 2.6.31
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17366 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.31/201-ap83_spi_controller.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.31/201-ap83_spi_controller.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.31/201-ap83_spi_controller.patch b/target/linux/ar71xx/patches-2.6.31/201-ap83_spi_controller.patch
new file mode 100644
index 0000000000..a8e889a7bd
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.31/201-ap83_spi_controller.patch
@@ -0,0 +1,27 @@
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -11,6 +11,7 @@ endif
+ obj-$(CONFIG_SPI_MASTER) += spi.o
+
+ # SPI master controller drivers (bus)
++obj-$(CONFIG_SPI_AP83) += ap83_spi.o
+ obj-$(CONFIG_SPI_AR71XX) += ar71xx_spi.o
+ obj-$(CONFIG_SPI_ATMEL) += atmel_spi.o
+ obj-$(CONFIG_SPI_BFIN) += spi_bfin5xx.o
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -53,6 +53,14 @@ if SPI_MASTER
+
+ comment "SPI Master Controller Drivers"
+
++config SPI_AP83
++ tristate "Atheros AP83 specific SPI Controller"
++ depends on SPI_MASTER && AR71XX_MACH_AP83
++ select SPI_BITBANG
++ help
++ This is a specific SPI controller driver for the Atheros AP83
++ reference board.
++
+ config SPI_AR71XX
+ tristate "Atheros AR71xx SPI Controller"
+ depends on SPI_MASTER && ATHEROS_AR71XX