aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.10/420-net-ar71xx_mac_driver.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-07-09 12:52:18 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-07-09 12:52:18 +0000
commitf42a1b166f43219853c00dc21f25b0254efbbceb (patch)
tree8fac5ee67f0a836a95385d15ae8f729d34660b9e /target/linux/ar71xx/patches-3.10/420-net-ar71xx_mac_driver.patch
parentf56e62651455e1a7cdae45a4a12d5258e57dbb75 (diff)
downloadmaster-187ad058-f42a1b166f43219853c00dc21f25b0254efbbceb.tar.gz
master-187ad058-f42a1b166f43219853c00dc21f25b0254efbbceb.tar.bz2
master-187ad058-f42a1b166f43219853c00dc21f25b0254efbbceb.zip
ar71xx: add linux 3.10
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37214 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-3.10/420-net-ar71xx_mac_driver.patch')
-rw-r--r--target/linux/ar71xx/patches-3.10/420-net-ar71xx_mac_driver.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.10/420-net-ar71xx_mac_driver.patch b/target/linux/ar71xx/patches-3.10/420-net-ar71xx_mac_driver.patch
new file mode 100644
index 0000000000..b6f8109d0d
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.10/420-net-ar71xx_mac_driver.patch
@@ -0,0 +1,28 @@
+--- a/drivers/net/ethernet/atheros/Kconfig
++++ b/drivers/net/ethernet/atheros/Kconfig
+@@ -5,7 +5,7 @@
+ config NET_VENDOR_ATHEROS
+ bool "Atheros devices"
+ default y
+- depends on PCI
++ depends on (PCI || ATH79)
+ ---help---
+ If you have a network (Ethernet) card belonging to this class, say Y
+ and read the Ethernet-HOWTO, available from
+@@ -85,4 +85,6 @@ config ALX
+ To compile this driver as a module, choose M here. The module
+ will be called alx.
+
++source drivers/net/ethernet/atheros/ag71xx/Kconfig
++
+ endif # NET_VENDOR_ATHEROS
+--- a/drivers/net/ethernet/atheros/Makefile
++++ b/drivers/net/ethernet/atheros/Makefile
+@@ -2,6 +2,7 @@
+ # Makefile for the Atheros network device drivers.
+ #
+
++obj-$(CONFIG_AG71XX) += ag71xx/
+ obj-$(CONFIG_ATL1) += atlx/
+ obj-$(CONFIG_ATL2) += atlx/
+ obj-$(CONFIG_ATL1E) += atl1e/