aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.10
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2014-07-14 21:30:26 +0000
committerGabor Juhos <juhosg@openwrt.org>2014-07-14 21:30:26 +0000
commit1b7feb924a73a2878a81c3b4804275f209ac07a7 (patch)
treebfbdf85a3d5d7705f7e3482525367e7c3e54296e /target/linux/ar71xx/patches-3.10
parentba1d7fecf8b29b7c91fb3c029924e6cf43382c44 (diff)
downloadmaster-187ad058-1b7feb924a73a2878a81c3b4804275f209ac07a7.tar.gz
master-187ad058-1b7feb924a73a2878a81c3b4804275f209ac07a7.tar.bz2
master-187ad058-1b7feb924a73a2878a81c3b4804275f209ac07a7.zip
ar71xx: add kernel support for the EnGenius EAP300 v2 board
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41658 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-3.10')
-rw-r--r--target/linux/ar71xx/patches-3.10/721-MIPS-ath79-add-EAP300v2-support.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.10/721-MIPS-ath79-add-EAP300v2-support.patch b/target/linux/ar71xx/patches-3.10/721-MIPS-ath79-add-EAP300v2-support.patch
new file mode 100644
index 0000000000..0d396b7008
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.10/721-MIPS-ath79-add-EAP300v2-support.patch
@@ -0,0 +1,38 @@
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
+@@ -50,6 +50,7 @@ enum ath79_mach_type {
+ ATH79_MACH_ESR900, /* EnGenius ESR900 */
+ ATH79_MACH_EW_DORIN, /* embedded wireless Dorin Platform */
+ ATH79_MACH_EW_DORIN_ROUTER, /* embedded wireless Dorin Router Platform */
++ ATH79_MACH_EAP300V2, /* EnGenius EAP300 v2 */
+ ATH79_MACH_EAP7660D, /* Senao EAP7660D */
+ ATH79_MACH_EL_M150, /* EasyLink EL-M150 */
+ ATH79_MACH_EL_MINI, /* EasyLink EL-MINI */
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
+@@ -396,6 +396,15 @@ config ATH79_MACH_GL_INET
+ select ATH79_DEV_USB
+ select ATH79_DEV_WMAC
+
++config ATH79_MACH_EAP300V2
++ bool "EnGenius EAP300 v2 support"
++ select SOC_AR934X
++ select ATH79_DEV_ETH
++ select ATH79_DEV_GPIO_BUTTONS
++ select ATH79_DEV_LEDS_GPIO
++ select ATH79_DEV_M25P80
++ select ATH79_DEV_WMAC
++
+ config ATH79_MACH_GS_OOLITE
+ bool "GS Oolite V1 support"
+ select SOC_AR933X
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
+@@ -62,6 +62,7 @@ obj-$(CONFIG_ATH79_MACH_DIR_825_C1) += m
+ obj-$(CONFIG_ATH79_MACH_DRAGINO2) += mach-dragino2.o
+ obj-$(CONFIG_ATH79_MACH_ESR900) += mach-esr900.o
+ obj-$(CONFIG_ATH79_MACH_EW_DORIN) += mach-ew-dorin.o
++obj-$(CONFIG_ATH79_MACH_EAP300V2) += mach-eap300v2.o
+ obj-$(CONFIG_ATH79_MACH_EAP7660D) += mach-eap7660d.o
+ obj-$(CONFIG_ATH79_MACH_EL_M150) += mach-el-m150.o
+ obj-$(CONFIG_ATH79_MACH_EL_MINI) += mach-el-mini.o