aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar7
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2008-11-24 21:52:10 +0000
committerFlorian Fainelli <florian@openwrt.org>2008-11-24 21:52:10 +0000
commit2503d8cc8397f183ba970eaa876bb49239c09505 (patch)
tree52abff4fd2f226c2ef33d1c93b0aee1848a4aba8 /target/linux/ar7
parent0e8b4d332692b146a64ff7325c82875db094a00f (diff)
downloadmaster-187ad058-2503d8cc8397f183ba970eaa876bb49239c09505.tar.gz
master-187ad058-2503d8cc8397f183ba970eaa876bb49239c09505.tar.bz2
master-187ad058-2503d8cc8397f183ba970eaa876bb49239c09505.zip
Fix this nasty patch which prevented others from applying
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13343 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar7')
-rw-r--r--target/linux/ar7/patches-2.6.26/110-flash.patch15
1 files changed, 2 insertions, 13 deletions
diff --git a/target/linux/ar7/patches-2.6.26/110-flash.patch b/target/linux/ar7/patches-2.6.26/110-flash.patch
index bda6e3727c..51b57f7986 100644
--- a/target/linux/ar7/patches-2.6.26/110-flash.patch
+++ b/target/linux/ar7/patches-2.6.26/110-flash.patch
@@ -13,25 +13,14 @@
comment "User Modules And Translation Layers"
config MTD_CHAR
---- a/drivers/mtd/Makefile
-+++ b/drivers/mtd/Makefile
-@@ -13,6 +13,7 @@ obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdli
- obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
- obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
- obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
-+obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
-
- # 'Users' - code which presents functionality to userspace.
- obj-$(CONFIG_MTD_CHAR) += mtdchar.o
--- a/drivers/mtd/maps/physmap.c
+++ b/drivers/mtd/maps/physmap.c
-@@ -87,7 +87,8 @@ static int physmap_flash_remove(struct p
+@@ -87,7 +87,7 @@
static const char *rom_probe_types[] = { "cfi_probe", "jedec_probe", "map_rom", NULL };
#ifdef CONFIG_MTD_PARTITIONS
-static const char *part_probe_types[] = { "cmdlinepart", "RedBoot", NULL };
-+static const char *part_probe_types[] = {"cmdlinepart", "RedBoot",
-+ "ar7part", NULL };
++static const char *part_probe_types[] = { "cmdlinepart", "RedBoot", "ar7part", NULL };
#endif
static int physmap_flash_probe(struct platform_device *dev)