aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91/patches
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2014-09-03 03:09:51 +0000
committerFlorian Fainelli <florian@openwrt.org>2014-09-03 03:09:51 +0000
commite244d02a5bac420e7c8308169d2d1bc37614a147 (patch)
tree122523850754b38227d401beacfe989bd6ea1752 /target/linux/at91/patches
parent00dc7e64d9671e53605466a90e0970ea8efb4862 (diff)
downloadmaster-187ad058-e244d02a5bac420e7c8308169d2d1bc37614a147.tar.gz
master-187ad058-e244d02a5bac420e7c8308169d2d1bc37614a147.tar.bz2
master-187ad058-e244d02a5bac420e7c8308169d2d1bc37614a147.zip
at91: move 3.10 specific files and patches
In preparation for adding 3.14 kernel support, move files and patches to a separate per-version directory since some of them will have incompatible changes (e.g: dts) Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42413 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/at91/patches')
-rw-r--r--target/linux/at91/patches/100-ARM-at91-build-dtb-for-LMU5000.patch10
-rw-r--r--target/linux/at91/patches/700-tqma9263-support.patch25
-rw-r--r--target/linux/at91/patches/805-free_some_portc_pins.patch11
-rw-r--r--target/linux/at91/patches/901-AT91-flexibity-default-leds-to-heartbeat.patch60
4 files changed, 0 insertions, 106 deletions
diff --git a/target/linux/at91/patches/100-ARM-at91-build-dtb-for-LMU5000.patch b/target/linux/at91/patches/100-ARM-at91-build-dtb-for-LMU5000.patch
deleted file mode 100644
index c631f8d588..0000000000
--- a/target/linux/at91/patches/100-ARM-at91-build-dtb-for-LMU5000.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/arch/arm/boot/dts/Makefile
-+++ b/arch/arm/boot/dts/Makefile
-@@ -23,6 +23,7 @@ dtb-$(CONFIG_ARCH_AT91) += tny_a9g20.dtb
- dtb-$(CONFIG_ARCH_AT91) += usb_a9g20.dtb
- # sam9g45
- dtb-$(CONFIG_ARCH_AT91) += at91sam9m10g45ek.dtb
-+dtb-$(CONFIG_ARCH_AT91) += lmu5000.dtb
- dtb-$(CONFIG_ARCH_AT91) += pm9g45.dtb
- # sam9n12
- dtb-$(CONFIG_ARCH_AT91) += at91sam9n12ek.dtb
diff --git a/target/linux/at91/patches/700-tqma9263-support.patch b/target/linux/at91/patches/700-tqma9263-support.patch
deleted file mode 100644
index d249783a3e..0000000000
--- a/target/linux/at91/patches/700-tqma9263-support.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- a/arch/arm/mach-at91/Kconfig.non_dt
-+++ b/arch/arm/mach-at91/Kconfig.non_dt
-@@ -258,6 +258,12 @@ config MACH_USB_A9263
- Select this if you are using a Calao Systems USB-A9263.
- <http://www.calao-systems.com>
-
-+config MACH_TQMA9263
-+ bool "TQ Components TQMa9263 board"
-+ help
-+ Select this if you are using the an TQ Components TQMa9263 board.
-+ <http://www.tq-components.com/>
-+
- endif
-
- # ----------------------------------------------------------
---- a/arch/arm/mach-at91/Makefile
-+++ b/arch/arm/mach-at91/Makefile
-@@ -68,6 +68,7 @@ obj-$(CONFIG_MACH_AT91SAM9G10EK) += boar
- # AT91SAM9263 board-specific support
- obj-$(CONFIG_MACH_AT91SAM9263EK) += board-sam9263ek.o
- obj-$(CONFIG_MACH_USB_A9263) += board-usb-a926x.o
-+obj-$(CONFIG_MACH_TQMA9263) += board-tqma9263.o
-
- # AT91SAM9RL board-specific support
- obj-$(CONFIG_MACH_AT91SAM9RLEK) += board-sam9rlek.o
diff --git a/target/linux/at91/patches/805-free_some_portc_pins.patch b/target/linux/at91/patches/805-free_some_portc_pins.patch
deleted file mode 100644
index a9694d1f01..0000000000
--- a/target/linux/at91/patches/805-free_some_portc_pins.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/arch/arm/mach-at91/at91sam9260_devices.c
-+++ b/arch/arm/mach-at91/at91sam9260_devices.c
-@@ -507,7 +507,7 @@ static struct platform_device at91sam926
- .num_resources = ARRAY_SIZE(spi1_resources),
- };
-
--static const unsigned spi1_standard_cs[4] = { AT91_PIN_PB3, AT91_PIN_PC5, AT91_PIN_PC4, AT91_PIN_PC3 };
-+static const unsigned spi1_standard_cs[2] = { AT91_PIN_PB3, AT91_PIN_PC5 };
-
- void __init at91_add_device_spi(struct spi_board_info *devices, int nr_devices)
- {
diff --git a/target/linux/at91/patches/901-AT91-flexibity-default-leds-to-heartbeat.patch b/target/linux/at91/patches/901-AT91-flexibity-default-leds-to-heartbeat.patch
deleted file mode 100644
index a97850ac91..0000000000
--- a/target/linux/at91/patches/901-AT91-flexibity-default-leds-to-heartbeat.patch
+++ /dev/null
@@ -1,60 +0,0 @@
---- a/arch/arm/mach-at91/board-flexibity.c
-+++ b/arch/arm/mach-at91/board-flexibity.c
-@@ -89,49 +89,49 @@ static struct gpio_led flexibity_leds[]
- .name = "usb1:green",
- .gpio = AT91_PIN_PA12,
- .active_low = 1,
-- .default_trigger = "default-on",
-+ .default_trigger = "heartbeat",
- },
- {
- .name = "usb1:red",
- .gpio = AT91_PIN_PA13,
- .active_low = 1,
-- .default_trigger = "default-on",
-+ .default_trigger = "heartbeat",
- },
- {
- .name = "usb2:green",
- .gpio = AT91_PIN_PB26,
- .active_low = 1,
-- .default_trigger = "default-on",
-+ .default_trigger = "heartbeat",
- },
- {
- .name = "usb2:red",
- .gpio = AT91_PIN_PB27,
- .active_low = 1,
-- .default_trigger = "default-on",
-+ .default_trigger = "heartbeat",
- },
- {
- .name = "usb3:green",
- .gpio = AT91_PIN_PC8,
- .active_low = 1,
-- .default_trigger = "default-on",
-+ .default_trigger = "heartbeat",
- },
- {
- .name = "usb3:red",
- .gpio = AT91_PIN_PC6,
- .active_low = 1,
-- .default_trigger = "default-on",
-+ .default_trigger = "heartbeat",
- },
- {
- .name = "usb4:green",
- .gpio = AT91_PIN_PB4,
- .active_low = 1,
-- .default_trigger = "default-on",
-+ .default_trigger = "heartbeat",
- },
- {
- .name = "usb4:red",
- .gpio = AT91_PIN_PB5,
- .active_low = 1,
-- .default_trigger = "default-on",
-+ .default_trigger = "heartbeat",
- }
- };
-