aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/atheros/patches-2.6.28/120-watchdog.patch
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2009-02-20 16:27:42 +0000
committerHauke Mehrtens <hauke@openwrt.org>2009-02-20 16:27:42 +0000
commitab82c57b352e2e5d45a4fa09816e5b29dc9ed231 (patch)
tree136db11a5fc8f4ef4dd9e448bb7c17945e605cd9 /target/linux/atheros/patches-2.6.28/120-watchdog.patch
parent35a6422eb6d4233328a68f238fb9a39d2ca56333 (diff)
downloadmaster-187ad058-ab82c57b352e2e5d45a4fa09816e5b29dc9ed231.tar.gz
master-187ad058-ab82c57b352e2e5d45a4fa09816e5b29dc9ed231.tar.bz2
master-187ad058-ab82c57b352e2e5d45a4fa09816e5b29dc9ed231.zip
[atheros]: Add initial kernel 2.6.28 support for atheros target.
The include files moved from /include/asm-mips/mach-atheros/ to /arch/mips/include/asm/mach-atheros/ This patch is based on the old kernel 2.6.27 patches. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14584 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/atheros/patches-2.6.28/120-watchdog.patch')
-rw-r--r--target/linux/atheros/patches-2.6.28/120-watchdog.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/atheros/patches-2.6.28/120-watchdog.patch b/target/linux/atheros/patches-2.6.28/120-watchdog.patch
new file mode 100644
index 0000000000..88c42a2a83
--- /dev/null
+++ b/target/linux/atheros/patches-2.6.28/120-watchdog.patch
@@ -0,0 +1,25 @@
+--- a/drivers/watchdog/Kconfig
++++ b/drivers/watchdog/Kconfig
+@@ -747,6 +747,12 @@ config TXX9_WDT
+ help
+ Hardware driver for the built-in watchdog timer on TXx9 MIPS SoCs.
+
++config ATHEROS_WDT
++ tristate "Atheros wisoc Watchdog Timer"
++ depends on ATHEROS
++ help
++ Hardware driver for the Atheros wisoc Watchdog Timer.
++
+ # PARISC Architecture
+
+ # POWERPC Architecture
+--- a/drivers/watchdog/Makefile
++++ b/drivers/watchdog/Makefile
+@@ -106,6 +106,7 @@ obj-$(CONFIG_WDT_RM9K_GPI) += rm9k_wdt.o
+ obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
+ obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
+ obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
++obj-$(CONFIG_ATHEROS_WDT) += ar2315-wtd.o
+
+ # PARISC Architecture
+