aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-02-14 20:48:20 +0000
committerJohn Crispin <blogic@openwrt.org>2015-02-14 20:48:20 +0000
commit066c67fc9699f3be5a5b4c746a6a4f857f77c2d2 (patch)
treebe9a695a9d69b8bd3a59b48b7f41a3ca57121081 /target/linux/brcm2708
parentf08b157a49b99b69b355ac7e98b558a2f7bf54bf (diff)
downloadmaster-187ad058-066c67fc9699f3be5a5b4c746a6a4f857f77c2d2.tar.gz
master-187ad058-066c67fc9699f3be5a5b4c746a6a4f857f77c2d2.tar.bz2
master-187ad058-066c67fc9699f3be5a5b4c746a6a4f857f77c2d2.zip
brcm2708: add kmod-hwmon-bcm2835 support and more missing symbols
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44449 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm2708')
-rw-r--r--target/linux/brcm2708/config-3.182
-rw-r--r--target/linux/brcm2708/modules.mk16
2 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/brcm2708/config-3.18 b/target/linux/brcm2708/config-3.18
index 908e74d731..873a0f64e2 100644
--- a/target/linux/brcm2708/config-3.18
+++ b/target/linux/brcm2708/config-3.18
@@ -223,6 +223,7 @@ CONFIG_RAW_DRIVER=y
CONFIG_SCSI=y
# CONFIG_SCSI_LOWLEVEL is not set
# CONFIG_SCSI_PROC_FS is not set
+# CONFIG_SENSORS_BCM2835 is not set
# CONFIG_SERIAL_8250 is not set
# CONFIG_SERIAL_AMBA_PL010 is not set
CONFIG_SERIAL_AMBA_PL011=y
@@ -235,6 +236,7 @@ CONFIG_SUSPEND=y
CONFIG_SUSPEND_FREEZER=y
CONFIG_SYS_SUPPORTS_APM_EMULATION=y
# CONFIG_TEXTSEARCH is not set
+# CONFIG_THERMAL_BCM2835 is not set
CONFIG_TMPFS_POSIX_ACL=y
CONFIG_UEVENT_HELPER_PATH=""
# CONFIG_UID16 is not set
diff --git a/target/linux/brcm2708/modules.mk b/target/linux/brcm2708/modules.mk
index 8f00990393..408382de5e 100644
--- a/target/linux/brcm2708/modules.mk
+++ b/target/linux/brcm2708/modules.mk
@@ -59,6 +59,22 @@ endef
$(eval $(call KernelPackage,spi-bcm2708))
+define KernelPackage/hwmon-bcm2835
+ TITLE:=BCM2835 HWMON driver
+ KCONFIG:=CONFIG_SENSORS_BCM2835
+ FILES:=$(LINUX_DIR)/drivers/hwmon/bcm2835-hwmon.ko
+ AUTOLOAD:=$(call AutoLoad,60,bcm2835-hwmon)
+ DEPENDS:=@TARGET_brcm2708
+ $(call AddDepends/hwmon,@TARGET_brcm2708)
+endef
+
+define KernelPackage/hwmon-bcm2835/description
+ Kernel module for BCM2835 thermal monitor chip
+endef
+
+$(eval $(call KernelPackage,hwmon-bcm2835))
+
+
I2C_BCM2708_MODULES:=\
CONFIG_I2C_BCM2708:drivers/i2c/busses/i2c-bcm2708