aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-10-11 16:23:18 +0000
committerJohn Crispin <blogic@openwrt.org>2015-10-11 16:23:18 +0000
commit15f6d595739607e3e5c965a79bb2a05ab47648b6 (patch)
tree1c44343553eae80cb802994e48d1c3f16a759260 /target/linux/brcm2708
parent16f9df0f85a4c2148be0ce434d9ce56304d31923 (diff)
downloadmaster-187ad058-15f6d595739607e3e5c965a79bb2a05ab47648b6.tar.gz
master-187ad058-15f6d595739607e3e5c965a79bb2a05ab47648b6.tar.bz2
master-187ad058-15f6d595739607e3e5c965a79bb2a05ab47648b6.zip
brcm2708: use mmd for overlays subdirectory
Fixes https://dev.openwrt.org/ticket/20704 Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47171 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm2708')
-rw-r--r--target/linux/brcm2708/image/Makefile9
1 files changed, 2 insertions, 7 deletions
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index 3744cace58..cc0bfb0a26 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -21,12 +21,6 @@ else
endef
endif
-define Image/Prepare
- rm -rf $(KDIR)/overlays
- mkdir -p $(KDIR)/overlays
- $(CP) $(DTS_DIR)/overlays/*.dtb $(KDIR)/overlays/
-endef
-
### Image scripts ###
define Build/gen-cfg
cat config.txt > $@.config
@@ -47,7 +41,8 @@ define Build/boot-img
mcopy -i $@.boot $@.config ::config.txt
mcopy -i $@.boot $(word 1,$^) ::kernel.img
mcopy -i $@.boot $(DTS_DIR)/$(DEVICE_DTS).dtb ::$(DEVICE_DTS).dtb
- mcopy -s -i $@.boot $(KDIR)/overlays ::
+ mmd -i $@.boot ::/overlays
+ mcopy -i $@.boot $(DTS_DIR)/overlays/*.dtb ::/overlays/
endef
define Build/sdcard-img