aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx-2.6/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-01-07 15:35:36 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-01-07 15:35:36 +0000
commit8ec22d8247fd6ca1653a0b8f1c5ee4d18789b490 (patch)
tree00eb8c51421887592f28d1679b0b4fbac9b0254a /target/linux/brcm47xx-2.6/Makefile
parentb12eed9aab8a95afe9e290dc4d4a597bb5f8ce5c (diff)
downloadmaster-187ad058-8ec22d8247fd6ca1653a0b8f1c5ee4d18789b490.tar.gz
master-187ad058-8ec22d8247fd6ca1653a0b8f1c5ee4d18789b490.tar.bz2
master-187ad058-8ec22d8247fd6ca1653a0b8f1c5ee4d18789b490.zip
Add initial version of the brcm-2.6 rewrite,
called brcm47xx-2.6 to better distinguish it from 63xx. Boots on WGT643U, includes ethernet support, but doesn't do much otherwise. Thanks to Michael Buesch for his SSB (Sonics SiliconBackplane) work and Vladdy for some fixes and porting to 2.6.19. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6015 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm47xx-2.6/Makefile')
-rw-r--r--target/linux/brcm47xx-2.6/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/brcm47xx-2.6/Makefile b/target/linux/brcm47xx-2.6/Makefile
new file mode 100644
index 0000000000..46e76503fc
--- /dev/null
+++ b/target/linux/brcm47xx-2.6/Makefile
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=mipsel
+BOARD:=brcm47xx
+BOARDNAME:=Broadcom BCM947xx/953xx (new code)
+FEATURES:=squashfs broken
+
+define Target/Description
+ Build firmware images for Broadcom based routers
+ (e.g. Linksys WRT54G(S), Asus WL-500g, Motorola WR850G)
+
+ This one builds the generic .trx images, activate one of the
+ options below for creating device specific files for use
+ with TFTP client too.
+endef
+
+include $(INCLUDE_DIR)/kernel-build.mk
+# DEFAULT_PACKAGES += kmod-switch
+
+$(eval $(call BuildKernel))