aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/image
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-06-17 22:57:04 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-06-17 22:57:04 +0000
commit23a7a4a036b01ab7bd2637a8d2b4e18fa80775b7 (patch)
tree84cd0052e57289a124a7de2dfcbc47e765593d76 /target/linux/brcm63xx/image
parent28aeb64578e996f9f79f57d31e677768ba8ee3e1 (diff)
downloadmaster-187ad058-23a7a4a036b01ab7bd2637a8d2b4e18fa80775b7.tar.gz
master-187ad058-23a7a4a036b01ab7bd2637a8d2b4e18fa80775b7.tar.bz2
master-187ad058-23a7a4a036b01ab7bd2637a8d2b4e18fa80775b7.zip
brcm63xx: create initramfs HCS images
Cable Modem devices cannot load an ELF file directly so we need to provide them with a HCS image even when targetting initramfs. Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36954 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm63xx/image')
-rwxr-xr-xtarget/linux/brcm63xx/image/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index 7875c5437d..4928010280 100755
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -157,6 +157,11 @@ define Image/Prepare
$(call prepare_generic_squashfs,$(KDIR)/fs_mark)
endef
+define Image/Build/Initramfs
+ # Netgear CVG834G
+ $(call Image/Build/HCS,initramfs,cvg834g,a020,0001,0022,$(KDIR)/vmlinux)
+endef
+
define Image/Build
dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
# Various routers
@@ -289,6 +294,9 @@ define Image/Build
# Netgear CVG834G
$(call Image/Build/HCS,$(1),cvg834g,a020,0001,0022,$(KDIR)/vmlinux)
endif
+ ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
+ $(call Image/Build/Initramfs)
+ endif
endef
$(eval $(call BuildImage))