aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/image
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-06-06 22:22:14 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-06-06 22:22:14 +0000
commit268ab6615153172e347f510b2941a44c6d3de0a0 (patch)
tree2807e553f6707fa5c43bf95e086994a376c07281 /target/linux/brcm63xx/image
parent25a96c2b766588892a40cb34df0b69b9a4aac459 (diff)
downloadmaster-187ad058-268ab6615153172e347f510b2941a44c6d3de0a0.tar.gz
master-187ad058-268ab6615153172e347f510b2941a44c6d3de0a0.tar.bz2
master-187ad058-268ab6615153172e347f510b2941a44c6d3de0a0.zip
brcm63xx: add kernel space and image support for the Netgear CVG834G
Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36876 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm63xx/image')
-rwxr-xr-xtarget/linux/brcm63xx/image/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index 69621dc5ae..754460731d 100755
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -11,6 +11,9 @@ LOADADDR = 0x80010000 # RAM start + 16M
KERNEL_ENTRY = $(LOADADDR) # Newer kernels add a jmp to the kernel_entry at the start of the binary
RAMSIZE = 0x01000000 # 64MB
+DROP_SECTIONS := .reginfo .mdebug .comment .note .pdr .options .MIPS.options
+OBJCOPY_BIN := $(TARGET_CROSS)objcopy -S -O binary $(addprefix --remove-section=,$(DROP_SECTIONS))
+
LOADER_MAKEOPTS= \
KDIR=$(KDIR) \
LOADADDR=$(LOADADDR) \
@@ -119,11 +122,19 @@ define Image/Build/CFEOLD
-o $(BIN_DIR)/openwrt-$(2)-$(1)-cfe.bin
endef
+define Image/Build/HCS
+ $(STAGING_DIR_HOST)/bin/hcsmakeimage --magic_byte=$(3) \
+ --rev_maj=$(4) --rev_min=$(5) --input_file=$(6) \
+ --output_file=$(BIN_DIR)/openwrt-$(2)-$(1).bin
+endef
+
define Build/Clean
$(MAKE) -C lzma-loader clean
endef
define Image/Prepare
+ # Binary kernel
+ $(OBJCOPY_BIN) $(LINUX_DIR)/vmlinux $(KDIR)/vmlinux.bin
# Standard LZMA kernel
cat $(KDIR)/vmlinux | $(STAGING_DIR_HOST)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
@@ -279,6 +290,9 @@ define Image/Build
# T-Com Speedport W 303V Typ B
$(call Image/Build/SPW303V,$(1),96358-502V,6358,SPW303V)
+
+ # Netgear CVG834G
+ $(call Image/Build/HCS,$(1),cvg834g,a020,0001,0022,$(KDIR)/vmlinux.bin)
endif
endef