aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/image
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2011-05-11 13:33:50 +0000
committerFlorian Fainelli <florian@openwrt.org>2011-05-11 13:33:50 +0000
commit93e4186e52cb545eb4ea364eea5077ecfc71ea4f (patch)
treea84efc8f34db130263f074e1f0d2b6c3e68f5f45 /target/linux/brcm63xx/image
parentbc014cb9cd0dff710d2ea8dee93ea2d139797cda (diff)
downloadmaster-187ad058-93e4186e52cb545eb4ea364eea5077ecfc71ea4f.tar.gz
master-187ad058-93e4186e52cb545eb4ea364eea5077ecfc71ea4f.tar.bz2
master-187ad058-93e4186e52cb545eb4ea364eea5077ecfc71ea4f.zip
bcm63xx: Update support for the DSL-274xB revision C
Rename the DSL-274xB rev C2's board ID to "AW4139" to match the one used for the rev C3 (same hardware) and add a fixup for C2. Also generate images for C3. While we are at it, rename the LEDs to conform to the Linux LED naming conventions. Signed-off-by: Jonas Gorski <jonas.gorski+openwrt@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26876 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm63xx/image')
-rw-r--r--target/linux/brcm63xx/image/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index 22d297137c..144f5559ea 100644
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -177,7 +177,9 @@ define Image/Build
# D-Link DSL-2640B
$(call Image/Build/CFE,$(1),D-4P-W,6348,DSL2640B)
# D-Link DSL-2740B/DSL-2741B, rev C2
- $(call Image/Build/CFE,$(1),96358GW,6358,DSL274XB-C2)
+ $(call Image/Build/CFEFIXUP,$(1),96358GW,AW4139,6358,DSL274XB-C2)
+ # D-Link DSL-2740B/DSL-2741B, rev C3
+ $(call Image/Build/CFE,$(1),AW4139,6358,DSL274XB-C3)
# TP-Link TD-8810A, TD-8810B, TD-8811A, TD-8811B
$(call Image/Build/CFE,$(1),8L-2M-8M,6338,TP8810_8811)