aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-07-14 09:57:45 +0000
committerJohn Crispin <blogic@openwrt.org>2015-07-14 09:57:45 +0000
commitb5bb9272ee773d30c1fde2da17c087618264ab6f (patch)
tree682cca857e1946d5a258823cfa55f3c40d9daa64 /target/linux/brcm63xx
parentb5f4a9f364263f9f1fdc5093b00b223154aaf5fc (diff)
downloadmaster-187ad058-b5bb9272ee773d30c1fde2da17c087618264ab6f.tar.gz
master-187ad058-b5bb9272ee773d30c1fde2da17c087618264ab6f.tar.bz2
master-187ad058-b5bb9272ee773d30c1fde2da17c087618264ab6f.zip
build: Prevent more gzip timestamps
To improve reproducibility, prevent the inclusion of timestamps in the gzip header. Signed-off-by: Reiner Herrmann <reiner@reiner-h.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46361 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm63xx')
-rwxr-xr-xtarget/linux/brcm63xx/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index e6dc2a8b57..63cd90a17d 100755
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -95,7 +95,7 @@ endef
define Image/Build/RedBootDTB
# Prepare kernel and rootfs
cat $(KDIR)/vmlinux $(DTS_DIR)/$(3).dtb > $(KDIR)/vmlinux-$(3)
- gzip -9 -c $(KDIR)/vmlinux-$(3) > $(KDIR)/vmlinux-$(3).bin.gz
+ gzip -9n -c $(KDIR)/vmlinux-$(3) > $(KDIR)/vmlinux-$(3).bin.gz
dd if=$(KDIR)/vmlinux-$(3).bin.gz of=$(BIN_DIR)/$(IMG_PREFIX)-$(2)-vmlinux.gz bs=65536 conv=sync
dd if=$(KDIR)/root.squashfs of="$(BIN_DIR)/$(IMG_PREFIX)-$(2)-root.squashfs" bs=64k conv=sync
echo -ne \\xDE\\xAD\\xC0\\xDE >> "$(BIN_DIR)/$(IMG_PREFIX)-$(2)-root.squashfs"