aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/cns21xx/profiles
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-12-30 17:19:16 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-12-30 17:19:16 +0000
commit0d46434b606a53fc835cbb70cad4bf03e99f613d (patch)
tree4b78a3202e08ca31ea33039589d221a2e19cbcf7 /target/linux/cns21xx/profiles
parent6c025a3167120ae374ba45a23d6d9067081cee49 (diff)
downloadmaster-187ad058-0d46434b606a53fc835cbb70cad4bf03e99f613d.tar.gz
master-187ad058-0d46434b606a53fc835cbb70cad4bf03e99f613d.tar.bz2
master-187ad058-0d46434b606a53fc835cbb70cad4bf03e99f613d.zip
cns21xx: add initial support for the Cavium CNS21xx SoC
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24859 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/cns21xx/profiles')
-rw-r--r--target/linux/cns21xx/profiles/00-default.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/cns21xx/profiles/00-default.mk b/target/linux/cns21xx/profiles/00-default.mk
new file mode 100644
index 0000000000..a2b669ed75
--- /dev/null
+++ b/target/linux/cns21xx/profiles/00-default.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+ NAME:=Default Profile (all drivers)
+ PACKAGES:= \
+ kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/Default/Description
+ Default package set compatible with most boards.
+endef
+$(eval $(call Profile,Default))