aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/cns21xx
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-06-27 19:58:31 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-06-27 19:58:31 +0000
commit704e2ed39d4e157d0c24d4dc3a3078cbacc6505c (patch)
treeffba1790b89941519ddb5acc2bf8f55df6b65529 /target/linux/cns21xx
parent5431c1983b51e4f69db63f5d5c94b2ed157e5374 (diff)
downloadmaster-187ad058-704e2ed39d4e157d0c24d4dc3a3078cbacc6505c.tar.gz
master-187ad058-704e2ed39d4e157d0c24d4dc3a3078cbacc6505c.tar.bz2
master-187ad058-704e2ed39d4e157d0c24d4dc3a3078cbacc6505c.zip
targets: prepare for supporting normal and initramfs images
In order to support both normal images and initramfs, ensure that each target sets KERNELNAME properly so that the generic kernel building code can copy the corresponding files over $(KDIR) with the appropriate extension. Update the various paths to the kernel and wrapper images from $(LINUX_DIR)/arch/$(ARCH)/boot/$(foo) to $(KDIR)/$(foo). Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37049 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/cns21xx')
-rw-r--r--target/linux/cns21xx/Makefile2
-rw-r--r--target/linux/cns21xx/image/Makefile2
2 files changed, 3 insertions, 1 deletions
diff --git a/target/linux/cns21xx/Makefile b/target/linux/cns21xx/Makefile
index 5970906be8..a08679589a 100644
--- a/target/linux/cns21xx/Makefile
+++ b/target/linux/cns21xx/Makefile
@@ -24,4 +24,6 @@ define Target/Description
Build firmware images for Cavium Networks CNS21XX based boards.
endef
+KERNELNAME:="zImage uImage"
+
$(eval $(call BuildTarget))
diff --git a/target/linux/cns21xx/image/Makefile b/target/linux/cns21xx/image/Makefile
index dd2d5d0c16..45dab986de 100644
--- a/target/linux/cns21xx/image/Makefile
+++ b/target/linux/cns21xx/image/Makefile
@@ -40,7 +40,7 @@ endef
define prepare_zimage
echo -en "\x$(2)\x1c\xa0\xe3\x$(3)\x10\x81\xe3" > $(KDIR)/$(call zimage_name,$(1))
- cat $(LINUX_DIR)/arch/arm/boot/zImage >> $(KDIR)/$(call zimage_name,$(1))
+ cat $(KDIR)/zImage >> $(KDIR)/$(call zimage_name,$(1))
endef
define prepare_uimage