aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/cns3xxx/patches-3.8/025-smp_support.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-07-31 23:40:49 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-07-31 23:40:49 +0000
commitac2d571b7d8bdcf6f53c6c266fb02cfb9686e65c (patch)
tree7ab55c9bbc8e965f5f7289891155e94c73193b80 /target/linux/cns3xxx/patches-3.8/025-smp_support.patch
parenta6b0a98d84acdda7b12226e4e0c46d0ca9e2d4f0 (diff)
downloadmaster-187ad058-ac2d571b7d8bdcf6f53c6c266fb02cfb9686e65c.tar.gz
master-187ad058-ac2d571b7d8bdcf6f53c6c266fb02cfb9686e65c.tar.bz2
master-187ad058-ac2d571b7d8bdcf6f53c6c266fb02cfb9686e65c.zip
cns3xxx: update to linux 3.10
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41917 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/cns3xxx/patches-3.8/025-smp_support.patch')
-rw-r--r--target/linux/cns3xxx/patches-3.8/025-smp_support.patch38
1 files changed, 0 insertions, 38 deletions
diff --git a/target/linux/cns3xxx/patches-3.8/025-smp_support.patch b/target/linux/cns3xxx/patches-3.8/025-smp_support.patch
deleted file mode 100644
index 82b1ce6f39..0000000000
--- a/target/linux/cns3xxx/patches-3.8/025-smp_support.patch
+++ /dev/null
@@ -1,38 +0,0 @@
---- a/arch/arm/mach-cns3xxx/Makefile
-+++ b/arch/arm/mach-cns3xxx/Makefile
-@@ -1,3 +1,5 @@
- obj-$(CONFIG_ARCH_CNS3XXX) += core.o pm.o devices.o
- obj-$(CONFIG_PCI) += pcie.o
- obj-$(CONFIG_MACH_CNS3420VB) += cns3420vb.o
-+obj-$(CONFIG_SMP) += platsmp.o headsmp.o
-+obj-$(CONFIG_HOTPLUG_CPU) += hotplug.o
---- a/arch/arm/Kconfig
-+++ b/arch/arm/Kconfig
-@@ -367,6 +367,7 @@ config ARCH_CNS3XXX
- select PCI_DOMAINS if PCI
- select CLKDEV_LOOKUP
- select CPU_CACHE_FORCE_MULTI
-+ select HAVE_SMP
- help
- Support for Cavium Networks CNS3XXX platform.
-
---- a/arch/arm/mach-cns3xxx/core.h
-+++ b/arch/arm/mach-cns3xxx/core.h
-@@ -11,6 +11,7 @@
- #ifndef __CNS3XXX_CORE_H
- #define __CNS3XXX_CORE_H
-
-+extern struct smp_operations cns3xxx_smp_ops;
- extern struct sys_timer cns3xxx_timer;
-
- #ifdef CONFIG_CACHE_L2X0
---- a/arch/arm/mach-cns3xxx/laguna.c
-+++ b/arch/arm/mach-cns3xxx/laguna.c
-@@ -989,6 +989,7 @@ static int __init laguna_model_setup(voi
- late_initcall(laguna_model_setup);
-
- MACHINE_START(GW2388, "Gateworks Corporation Laguna Platform")
-+ .smp = smp_ops(cns3xxx_smp_ops),
- .atag_offset = 0x100,
- .map_io = laguna_map_io,
- .init_irq = cns3xxx_init_irq,