aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/coldfire/patches-2.6.31/007-bcm5222_phy.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2010-11-22 13:29:58 +0000
committerImre Kaloz <kaloz@openwrt.org>2010-11-22 13:29:58 +0000
commit69b87e767b7dc9ffe8c3081e9921aa0891d068ee (patch)
tree944d6066a1b5ba2fdc838200893e6d122bbc7650 /target/linux/coldfire/patches-2.6.31/007-bcm5222_phy.patch
parent1b6808066b4288d148d00e930c433396406f34c2 (diff)
downloadmaster-187ad058-69b87e767b7dc9ffe8c3081e9921aa0891d068ee.tar.gz
master-187ad058-69b87e767b7dc9ffe8c3081e9921aa0891d068ee.tar.bz2
master-187ad058-69b87e767b7dc9ffe8c3081e9921aa0891d068ee.zip
[coldfire]: 2.6.31 support (WiP)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24087 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/coldfire/patches-2.6.31/007-bcm5222_phy.patch')
-rw-r--r--target/linux/coldfire/patches-2.6.31/007-bcm5222_phy.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/coldfire/patches-2.6.31/007-bcm5222_phy.patch b/target/linux/coldfire/patches-2.6.31/007-bcm5222_phy.patch
new file mode 100644
index 0000000000..554fa6833d
--- /dev/null
+++ b/target/linux/coldfire/patches-2.6.31/007-bcm5222_phy.patch
@@ -0,0 +1,24 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -62,6 +62,11 @@ config BROADCOM_PHY
+ Currently supports the BCM5411, BCM5421, BCM5461, BCM5464, BCM5481
+ and BCM5482 PHYs.
+
++config BROADCOM5222_PHY
++ tristate "Drivers for Broadcom5222 PHY"
++ ---help---
++ Currently supports the BCM5222 PHYs.
++
+ config ICPLUS_PHY
+ tristate "Drivers for ICPlus PHYs"
+ ---help---
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -12,6 +12,7 @@ obj-$(CONFIG_QSEMI_PHY) += qsemi.o
+ obj-$(CONFIG_SMSC_PHY) += smsc.o
+ obj-$(CONFIG_VITESSE_PHY) += vitesse.o
+ obj-$(CONFIG_BROADCOM_PHY) += broadcom.o
++obj-$(CONFIG_BROADCOM5222_PHY) += broadcom522x.o
+ obj-$(CONFIG_ICPLUS_PHY) += icplus.o
+ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
+ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o