aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/easygate-2.6/image/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-04-10 21:46:29 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-04-10 21:46:29 +0000
commitc50002315a37c8aa8e985f442ea59d7549da1ba2 (patch)
tree0953091dc5ddee39b2121bed1252fb74383cf595 /target/linux/easygate-2.6/image/Makefile
parent14d9a22d8896ab25712c2eb527dbf3dd31e32cd2 (diff)
downloadmaster-187ad058-c50002315a37c8aa8e985f442ea59d7549da1ba2.tar.gz
master-187ad058-c50002315a37c8aa8e985f442ea59d7549da1ba2.tar.bz2
master-187ad058-c50002315a37c8aa8e985f442ea59d7549da1ba2.zip
Ajoute le support easygate
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6926 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/easygate-2.6/image/Makefile')
-rw-r--r--target/linux/easygate-2.6/image/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/target/linux/easygate-2.6/image/Makefile b/target/linux/easygate-2.6/image/Makefile
new file mode 100644
index 0000000000..d930af8501
--- /dev/null
+++ b/target/linux/easygate-2.6/image/Makefile
@@ -0,0 +1,48 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+LOADADDR = 0x8108c8f4 # RAM start + 16M
+KERNEL_ENTRY = 0x80100000 # Default kernel entry in arch/mips/Makefile
+RAMSIZE = 0x01000000 # 64MB
+
+LOADER_MAKEOPTS= \
+ KDIR=$(KDIR) \
+ LOADADDR=$(LOADADDR) \
+ KERNEL_ENTRY=$(KERNEL_ENTRY) \
+ RAMSIZE=$(RAMSIZE)
+
+define trxalign/jffs2-128k
+-a 0x20000
+endef
+define trxalign/jffs2-64k
+-a 0x10000
+endef
+define trxalign/squashfs
+-a 1024
+endef
+
+define Build/Clean
+ $(MAKE) -C lzma-loader clean
+endef
+
+define Image/Prepare
+ cat $(KDIR)/vmlinux | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
+ rm -f $(KDIR)/loader.gz
+ $(MAKE) -C lzma-loader \
+ BUILD_DIR="$(KDIR)" \
+ TARGET="$(KDIR)" \
+ clean install
+ echo -ne "\\x00" >> $(KDIR)/loader.gz
+endef
+
+define Image/Build
+ $(STAGING_DIR)/bin/trx -o $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).trx -f $(KDIR)/loader.gz -f $(KDIR)/vmlinux.lzma $(call trxalign/$(1)) -f $(KDIR)/root.$(1)
+endef
+
+$(eval $(call BuildImage))