aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/files-2.6.23/drivers/ssb/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-10-18 21:43:30 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-10-18 21:43:30 +0000
commitaf835ce5169cc7829928e8e224508526b9ef2870 (patch)
tree093db669aa3ce1faaf10c4575bb61d502918bedc /target/linux/generic-2.6/files-2.6.23/drivers/ssb/Makefile
parentdabd596e39c58eddc0f2361d12f415d5482307aa (diff)
downloadmaster-187ad058-af835ce5169cc7829928e8e224508526b9ef2870.tar.gz
master-187ad058-af835ce5169cc7829928e8e224508526b9ef2870.tar.bz2
master-187ad058-af835ce5169cc7829928e8e224508526b9ef2870.zip
change the way ./files* and the generic kernel files are applied. ./files now applies to *ALL* kernel versions, and is copied along with ./files-* - this gets rid of quite a bit of redundancy in the extra kernel drivers.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13010 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/files-2.6.23/drivers/ssb/Makefile')
-rw-r--r--target/linux/generic-2.6/files-2.6.23/drivers/ssb/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/files-2.6.23/drivers/ssb/Makefile b/target/linux/generic-2.6/files-2.6.23/drivers/ssb/Makefile
new file mode 100644
index 0000000000..7be3975958
--- /dev/null
+++ b/target/linux/generic-2.6/files-2.6.23/drivers/ssb/Makefile
@@ -0,0 +1,18 @@
+# core
+ssb-y += main.o scan.o
+
+# host support
+ssb-$(CONFIG_SSB_PCIHOST) += pci.o pcihost_wrapper.o
+ssb-$(CONFIG_SSB_PCMCIAHOST) += pcmcia.o
+
+# built-in drivers
+ssb-y += driver_chipcommon.o
+ssb-$(CONFIG_SSB_DRIVER_MIPS) += driver_mipscore.o
+ssb-$(CONFIG_SSB_DRIVER_EXTIF) += driver_extif.o
+ssb-$(CONFIG_SSB_DRIVER_PCICORE) += driver_pcicore.o
+
+# b43 pci-ssb-bridge driver
+# Not strictly a part of SSB, but kept here for convenience
+ssb-$(CONFIG_SSB_PCIHOST) += b43_pci_bridge.o
+
+obj-$(CONFIG_SSB) += ssb.o