aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/files/fs/yaffs2/Makefile
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2007-10-10 18:05:48 +0000
committerGabor Juhos <juhosg@openwrt.org>2007-10-10 18:05:48 +0000
commit19b593fb35debd86731310c59edf1a547c566eae (patch)
tree35d1b80970bc9582e6bdbd7d0a3abecc81dda981 /target/linux/generic-2.6/files/fs/yaffs2/Makefile
parentc7183451a877cb39a7be5c43d7ecd276f477e3ef (diff)
downloadmaster-187ad058-19b593fb35debd86731310c59edf1a547c566eae.tar.gz
master-187ad058-19b593fb35debd86731310c59edf1a547c566eae.tar.bz2
master-187ad058-19b593fb35debd86731310c59edf1a547c566eae.zip
[kernel] dissect yaffs patch
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9249 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/files/fs/yaffs2/Makefile')
-rw-r--r--target/linux/generic-2.6/files/fs/yaffs2/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/files/fs/yaffs2/Makefile b/target/linux/generic-2.6/files/fs/yaffs2/Makefile
new file mode 100644
index 0000000000..73f46583f4
--- /dev/null
+++ b/target/linux/generic-2.6/files/fs/yaffs2/Makefile
@@ -0,0 +1,11 @@
+#
+# Makefile for the linux YAFFS filesystem routines.
+#
+
+obj-$(CONFIG_YAFFS_FS) += yaffs.o
+
+yaffs-y := yaffs_ecc.o yaffs_fs.o yaffs_guts.o yaffs_checkptrw.o
+yaffs-y += yaffs_packedtags2.o yaffs_nand.o yaffs_qsort.o
+yaffs-y += yaffs_tagscompat.o yaffs_tagsvalidity.o
+yaffs-y += yaffs_mtdif1.o yaffs_packedtags1.o
+yaffs-y += yaffs_mtdif.o yaffs_mtdif2.o