aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/image/lzma-loader/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2008-03-26 13:33:22 +0000
committerFlorian Fainelli <florian@openwrt.org>2008-03-26 13:33:22 +0000
commit98eaccc6d386752bfb81ad52e6cb559329b07740 (patch)
tree33f69544d15fb0b90b0eda6bc6d24437b932c856 /target/linux/generic-2.6/image/lzma-loader/Makefile
parent9032445f3ae8d1e97929274f2ae72f06b4ae100c (diff)
downloadmaster-187ad058-98eaccc6d386752bfb81ad52e6cb559329b07740.tar.gz
master-187ad058-98eaccc6d386752bfb81ad52e6cb559329b07740.tar.bz2
master-187ad058-98eaccc6d386752bfb81ad52e6cb559329b07740.zip
Generate a binary lzma-loader
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10661 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/image/lzma-loader/Makefile')
-rw-r--r--target/linux/generic-2.6/image/lzma-loader/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/target/linux/generic-2.6/image/lzma-loader/Makefile b/target/linux/generic-2.6/image/lzma-loader/Makefile
index e3a98afbce..171c3c3938 100644
--- a/target/linux/generic-2.6/image/lzma-loader/Makefile
+++ b/target/linux/generic-2.6/image/lzma-loader/Makefile
@@ -33,11 +33,15 @@ $(PKG_BUILD_DIR)/vmlinux.lzma: $(KDIR)/vmlinux.lzma
$(KDIR)/loader$(LOADER_TYPE).elf: $(PKG_BUILD_DIR)/lzma.elf
$(CP) $< $@
+$(KDIR)/loader$(LOADER_TYPE).bin: $(PKG_BUILD_DIR)/lzma.bin
+ $(CP) $< $@
+
download:
prepare: $(PKG_BUILD_DIR)/.prepared
-compile: $(KDIR)/loader$(LOADER_TYPE).elf
+compile: $(KDIR)/loader$(LOADER_TYPE).elf $(KDIR)/loader$(LOADER_TYPE).bin
install:
clean:
rm -rf $(PKG_BUILD_DIR)
rm -f $(KDIR)/loader.elf
+ rm -f $(KDIR)/loader.bin