aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.23/171-netfilter_tarpit.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-05-18 20:24:51 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-05-18 20:24:51 +0000
commitd428b782b3b5bd8afc8d96fb6ef79d9309c2a1ef (patch)
tree239f266c8decd7ec360cd1fd1d7bafc53389618f /target/linux/generic-2.6/patches-2.6.23/171-netfilter_tarpit.patch
parent56fc181f20196a0baa22154fd55bbccc870e709d (diff)
downloadmaster-187ad058-d428b782b3b5bd8afc8d96fb6ef79d9309c2a1ef.tar.gz
master-187ad058-d428b782b3b5bd8afc8d96fb6ef79d9309c2a1ef.tar.bz2
master-187ad058-d428b782b3b5bd8afc8d96fb6ef79d9309c2a1ef.zip
[kernel] refresh generic 2.6.23 patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11187 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.23/171-netfilter_tarpit.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.23/171-netfilter_tarpit.patch16
1 files changed, 8 insertions, 8 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.23/171-netfilter_tarpit.patch b/target/linux/generic-2.6/patches-2.6.23/171-netfilter_tarpit.patch
index 073951a15c..847d47427e 100644
--- a/target/linux/generic-2.6/patches-2.6.23/171-netfilter_tarpit.patch
+++ b/target/linux/generic-2.6/patches-2.6.23/171-netfilter_tarpit.patch
@@ -1,7 +1,7 @@
-Index: linux-2.6.23.16/net/netfilter/Kconfig
+Index: linux-2.6.23.17/net/netfilter/Kconfig
===================================================================
---- linux-2.6.23.16.orig/net/netfilter/Kconfig
-+++ linux-2.6.23.16/net/netfilter/Kconfig
+--- linux-2.6.23.17.orig/net/netfilter/Kconfig
++++ linux-2.6.23.17/net/netfilter/Kconfig
@@ -401,6 +401,23 @@ config NETFILTER_XT_TARGET_CONNSECMARK
To compile it as a module, choose M here. If unsure, say N.
@@ -26,10 +26,10 @@ Index: linux-2.6.23.16/net/netfilter/Kconfig
config NETFILTER_XT_TARGET_TCPMSS
tristate '"TCPMSS" target support'
depends on NETFILTER_XTABLES && (IPV6 || IPV6=n)
-Index: linux-2.6.23.16/net/netfilter/Makefile
+Index: linux-2.6.23.17/net/netfilter/Makefile
===================================================================
---- linux-2.6.23.16.orig/net/netfilter/Makefile
-+++ linux-2.6.23.16/net/netfilter/Makefile
+--- linux-2.6.23.17.orig/net/netfilter/Makefile
++++ linux-2.6.23.17/net/netfilter/Makefile
@@ -47,6 +47,7 @@ obj-$(CONFIG_NETFILTER_XT_TARGET_NFLOG)
obj-$(CONFIG_NETFILTER_XT_TARGET_NOTRACK) += xt_NOTRACK.o
obj-$(CONFIG_NETFILTER_XT_TARGET_TRACE) += xt_TRACE.o
@@ -38,10 +38,10 @@ Index: linux-2.6.23.16/net/netfilter/Makefile
obj-$(CONFIG_NETFILTER_XT_TARGET_TCPMSS) += xt_TCPMSS.o
obj-$(CONFIG_NETFILTER_XT_TARGET_CONNSECMARK) += xt_CONNSECMARK.o
obj-$(CONFIG_NETFILTER_XT_TARGET_CHAOS) += xt_CHAOS.o
-Index: linux-2.6.23.16/net/netfilter/xt_TARPIT.c
+Index: linux-2.6.23.17/net/netfilter/xt_TARPIT.c
===================================================================
--- /dev/null
-+++ linux-2.6.23.16/net/netfilter/xt_TARPIT.c
++++ linux-2.6.23.17/net/netfilter/xt_TARPIT.c
@@ -0,0 +1,280 @@
+/*
+ * Kernel module to capture and hold incoming TCP connections using